4

Consider the following MWE:

\documentclass{scrartcl}

\usepackage{pdfx}

\begin{document}
test
\end{document}

If compiled via lualatex test.tex I receive the following warning:

Package hyperref Warning: Wrong driver `hpdftex.def';
(hyperref)                pdfTeX is running in PDF mode.
(hyperref)                Forcing driver `hluatex.def'.


Package hyperref Message: Driver: hluatex.

I'm not sure how severe the warning ist. Can someone clarify if I can ignore this warning, or even better how I can resolve the warning.

LuaTeX, Version 0.95.0 (TeX Live 2016)

pdfx 1.5.8/2016/05/03

  • 2
    You can ignore the warning: hyperref loads the correct driver. Really resolve it can only the author of the package. – Ulrike Fischer Mar 24 '17 at 11:09
  • Agreed. Not a problem. – user103221 Mar 24 '17 at 14:17
  • The issue was fixed with pdfx 2017/05/18 v1.5.84. – s4ndm4n May 22 '17 at 8:57
  • If you were able to update to TL17 this question would be solved. Is that an option for you? – TeXnician Jul 1 '17 at 8:10
  • 4
    I'm voting to close this question as off-topic because issue with luatex changes fixed by package in later releases. – David Carlisle Oct 15 '17 at 21:47