1

when I moved the dvips from the usepackage, the image loaded but the margin will be reduced. If I kept the dvips, the image does not show on the paper.

the code in thesis.tex is

\documentclass[12pt,a4paper,twoside,openright]{report}

\usepackage[dvips]{graphicx}
\usepackage{tabularx}
\usepackage{subfigure}
\usepackage{afterpage}
\usepackage{amsmath,amssymb}            
\usepackage{rotating}  
\usepackage{fancyhdr}  
\usepackage[scriptsize]{caption} 

\usepackage[setpagesize=false]{hyperref}

\hyphenation{a-gen-tiz-za-zio-ne}

\setlength{\paperwidth}{16cm}
\setlength{\paperheight}{24cm}
\setlength{\oddsidemargin} {2. cm}
\setlength{\evensidemargin} {2. cm}
\addtolength{\oddsidemargin} {-0.4 cm}
\addtolength{\evensidemargin} {-0.4 cm}
\linespread{1.1}

\usepackage[italian,english]{babel}
\usepackage[latin1]{inputenc}
\renewcommand{\captionfont}{\normalfont \sffamily \itshape \small}


\pagestyle{empty}

\begin{document}
\include{cover}
\thispagestyle{empty} \normalfont \cleardoublepage
\include{dedication}
\thispagestyle{empty}  \cleardoublepage
\pagenumbering{arabic}
\include{abstract}
\thispagestyle{empty} \vspace*{.75truecm} \cleardoublepage
\include{thanks}
\thispagestyle{empty} \vspace*{.75truecm} \normalfont \cleardoublepage
\pagestyle{plain}\renewcommand{\chaptermark}[1]{\markboth{\chaptername\ \thechapter.\ #1}{}} 
\renewcommand{\sectionmark}[1]{\markright{\thesection.\ #1}}         
\fancyhead[LE,RO]{\bfseries\thepage}    

\fancyhead[RE]{\bfseries\leftmark}    
\fancyhead[LO]{\bfseries\rightmark}     
\renewcommand{\headrulewidth}{0.3pt} 

\tableofcontents


\include{capitolo1}
\include{capitolo2}
\include{chapter3}

\cleardoublepage
% ---- Bibliography ----
\addcontentsline{toc}{chapter}{Bibliography}
\bibliographystyle{plain}
\bibliography{biblio}
%\nocite{*}

\appendix

\pagestyle{fancy} 
\fancyfoot{}                                               
\renewcommand{\chaptermark}[1]{\markboth{\appendixname\ \thechapter.\ #1}{}} 
\renewcommand{\sectionmark}[1]{\markright{\thesection.\ #1}}         
\fancyhead[LE,RO]{\bfseries\thepage}    

\fancyhead[RE]{\bfseries\leftmark}    
\fancyhead[LO]{\bfseries\rightmark}     
\renewcommand{\headrulewidth}{0.3pt} 

\end{document}

and code in cover.tex is

\thispagestyle{empty}
%\begin{titlepage}
\vspace*{-1.5cm} \bfseries{
\begin{center}
  \large
  POLITECNICO DI MILANO\\
  \normalsize
  Corso di Laurea MAGISTRALE in Ingegneria Informatica\\
  Dipartimento di Elettronica e Informazione\\
  \begin{figure}[htbp]
    \begin{center}
      \includegraphics[width=3.5cm]{./pictures/logopm}
%   \psfig{file=./pictures/logopm.jpg,width=3.5cm}
    \end{center}
  \end{figure}
  \vspace*{0.3cm} \LARGE



  \textbf{Analysis of Different Footprints for JPEG Compression Detection}\\



  \vspace*{.75truecm} \large

\end{center}
\vspace*{3.0cm} \large
\begin{flushleft}


  Supervisor: Prof.Paolo Bestagini \\
  Associate Supervisor: Dr.Luca Bondi

\end{flushleft}
\vspace*{1.0cm}
\begin{flushright}


  Tesi di Laurea di:\\ Chen Ke, matricola 833240 \\ 



\end{flushright}
\vspace*{0.5cm}
\begin{center}



  Anno Accademico 2016-2017
\end{center} \clearpage
}
  • 2
    you do not say but presumably you are not using latex and dvips but pdflatex? in which case remove the dvips option and then set whatever page size/margins you need using the geometry package. – David Carlisle Mar 25 '17 at 21:29
  • 1
    I think that at least knowing which engine are you using is in order... – Moriambar Mar 25 '17 at 21:40
  • 1
    but you have not said what program you are using to typeset the document (nor shown any usable code) if you are not using latex+dvips do not use the dvips option otherwise nothing will work. If th epage margins are wrong then the simplest way to fix them is using the geometry package as I said above. i can not guess what you mean by /setlength(/paperwidth=16cm,/paperheight=24cm,/oddsidemargin‌​=/evensidemargin=2cm‌​), /addtolength(/oddsidemargin=/evensidemargin=-0.4) as it isn't tex syntax at all – David Carlisle Mar 25 '17 at 22:05
  • 1
    @Chan, please move code from your comment to question! – Zarko Mar 25 '17 at 22:24
  • 1
    @Chan Thanks for adding the code to your question, but please can you replace the images with copyable code? We don't want to retype everything. And can you please answer the questions which tex engine you are using? – user36296 Mar 25 '17 at 22:34
1

dvips is no option to be used with pdflatex, simply remove it.

With your specific document, this means that now your setting for paperwidth, margins etc. are taken into account - so adjust (or remove) these numbers to get back the large margins you are used to from the dvips option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.