5

When I write in \gre \textbf{} does not work, but when I write in \lat everything is in bold and I cannot convert it to normal with {\normalfont } I use an assignment template from ShareLatex:

%%% Template originaly created by Karol Kozioł (mail@karol-koziol.net) and modified for ShareLaTeX use

\documentclass[a4paper,11pt]{article}

\usepackage[english,greek]{babel}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{graphicx}
\usepackage{xcolor}
\usepackage{tgtermes}
\usepackage{amsfonts}

newcommand{\lat}{\selectlanguage{english}}
\newcommand{\gre}{\selectlanguage{greek}}

\usepackage[
pdftitle={Math Assignment}, 
pdfauthor={Joe Doe, Some University},
colorlinks=true,linkcolor=blue,urlcolor=blue,citecolor=blue,bookmarks=true,
bookmarksopenlevel=2]{hyperref}
\usepackage{amsmath,amssymb,amsthm,textcomp}
\usepackage{enumerate}
\usepackage{multicol}
\usepackage{tikz}

\usepackage{geometry}
\geometry{total={210mm,297mm},
left=25mm,right=25mm,%
bindingoffset=0mm, top=20mm,bottom=20mm}


\linespread{1.3}

\newcommand{\linia}{\rule{\linewidth}{0.5pt}}

% custom theorems if needed
\newtheoremstyle{mytheor}
{1ex}{1ex}{\normalfont}{0pt}{\scshape}{.}{1ex}
{{\thmname{#1 }}{\thmnumber{#2}}{\thmnote{ (#3)}}}

\theoremstyle{mytheor}
\newtheorem{defi}{Definition}

% my own titles
\makeatletter
\renewcommand{\maketitle}{
\begin{center}
\vspace{2ex}
{\huge \textsc{\@title}}
\vspace{1ex}
\\
\linia\\
\@author \hfill \@date
\vspace{4ex}
\end{center}
}
\makeatother
%%%

% custom footers and headers
\usepackage{fancyhdr,lastpage}
\pagestyle{fancy}
\lhead{}
\chead{}
\rhead{}
%\lfoot{Assignment \textnumero{} 5}
%\cfoot{}
%\rfoot{Page \thepage\ /\ \pageref*{LastPage}}
\renewcommand{\headrulewidth}{0pt}
%\renewcommand{\footrulewidth}{0pt}
%

%%%----------%%%----------%%%----------%%%----------%%%

For example {\gre \textbf{Άσκηση}} and {\lat exercise}

  • Check your log file for font warnings. Most likely some greek font variant is missing – siracusa Mar 27 '17 at 18:33
  • 2
    Probably you don't have bold greek fonts, they are difficult to find – Moriambar Mar 27 '17 at 18:35
  • Further investigation results in tgtermes package overriding the standard greek font (I think LaTeX uses cbgreek-complete) which has bold – Moriambar Mar 27 '17 at 18:41
  • besides greek, why everything in english is shown in bold? – asdf Mar 27 '17 at 18:42
  • 1
    I don't have this behaviour: please extend your code sample including your usage of the \lat command. – Moriambar Mar 27 '17 at 18:46
3

I don't really know if tgtermes even has a bold variant of Greek font (if so, you're better off with the computer modern variant, as searching for the right templates of such peculiar fonts is pretty much the definition of masochism). Since you didn't specify the necessity of a specific font, I think my answer should suffice. You will probably dislike the change of font, but when you see all the vast options that come with it (and would probably induce some errors when paired with other fonts) you might reconsider.

The code.

\documentclass[a4paper,11pt]{article}

\usepackage[english,greek]{babel}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}

\newcommand{\lat}{\selectlanguage{english}}
\newcommand{\gre}{\selectlanguage{greek}}

\begin{document}

\setlength{\parindent}{0cm}

{\lat It works!} \\
{\lat \textbf{It works!}} \\
{\lat \textit{It works!}} \\
{\lat \textbf{\textit{It works!}}} \\\\
{\gre It works!} \\
{\gre \textbf{It works!}} \\
{\gre \textit{It works!}} \\
{\gre \textbf{\textit{It works!}}}

\end{document}

The result.

enter image description here

3

The tgtermes package doesn't support Greek. You can use tempora, instead.

Please, avoid \gre defined in that fashion. I suggest two different macros that take an argument: \greek{<text in Greek>} and \english{<text in English>}.

In the example code I only left the necessary packages, add the others you need, but remember that (apart from some exceptions you aren't loading) hyperref must go last.

\documentclass[a4paper,11pt]{article}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[english,greek]{babel}

\usepackage{tempora}

% hyperref should go LAST
\usepackage[
  pdftitle={Math Assignment},
  pdfauthor={Joe Doe, Some University},
  colorlinks=true,linkcolor=blue,urlcolor=blue,citecolor=blue,bookmarks=true,
  bookmarksopenlevel=2
]{hyperref}

\newcommand{\english}{\foreignlanguage{english}}
\newcommand{\greek}{\foreignlanguage{greek}}

\begin{document}

Ελληνική είναι η προεπιλεγμένη γλώσσα \english{exercise}

\textbf{Ελληνική}

\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.