1

I'm using TexMaker, I want the files generated by the compilation of my .tex files to be put in a subdirectory. I checked the box (by going to Preferences > Commands)

use "build" subdirectory for output files

but I keep being prompted with the dialog "log file not found" multiple times during the compilation and, at the end, the files are not generated in any build subfolder. This dialog is shown only if I have that box checked.

Currently, my quick build is "pdflatex + bib(la)tex + 2xpdflatex + pdfviewer".

More specifically, these are my configurations:

For pdflatex:

"/Library/TeX/Distributions/.DefaultTeX/Contents/Programs/texbin/pdflatex" -synctex=1 -interaction=nonstopmode %.tex

For Bib(la)tex, if I use either

"/Library/TeX/Distributions/.DefaultTeX/Contents/Programs/texbin/bibtex" build/%.aux

or

"/Library/TeX/Distributions/.DefaultTeX/Contents/Programs/texbin/bibtex" %.aux

I keep being prompted with the dialog "log file not found".

How can I solve this problem? I have already looked around for solutions, but I've not managed to find one for my particular case that works.

By the way, I have all but the main .tex file in a subdirectory called /tex, in case it matters. I also tried to add at the end of the of the pdflatex command the option --output-directory=mysubdir or with -output-directory=mysubdir, but the files are not generated in this my mysubdir, which is not even created, on the other hand, in this case, I'm not being prompted with the "log file not found" dialogs.

By doing pdflatex -help on the terminal, I see that my pdflatex actually requires the option -output-directory=mysubdir (i.e. with only one dash in the front), but the tooltip that pops up when I go over the checkbox use "build" subdirectory for output files says that it's going to add the option --output-directory=build (i.e. with two dashes in front). This could be a problem, but, in any case, I should be able to generate the compiled files in a subdirectory by adding the option manually to the pdflatex command (as I did), but it doesn't generate the files in the subdirectory (as I said).

  • Are you using the biblatex package as your tagging suggests, or are you using BibTeX styles (.bst with \bibliographystyle)? Have a look at tex.stackexchange.com/q/12686 and tex.stackexchange.com/q/46016 – moewe Mar 28 '17 at 10:50
  • @moewe I'm using .bib extensions with \bibliographystyle. – nbro Mar 28 '17 at 10:54
  • Since you are using \bibliographystyle that means you are not using biblatex. So I will re-tag your question. Note that the 'build' subdirectory stuff is normally not worth the hassle. – moewe Mar 28 '17 at 10:55
  • @moewe The editor is configured to use biblatex, so I don't understand then why if I use \bibliographystyle it doesn't give me an error. – nbro Apr 2 '17 at 19:40
  • Your editor cannot be configures to use biblatex. It can either run Biber (which is biblatex only) or BibTeX (which can be used for traditional \bibliographystyle or as legacy backend for biblatex). Some editors incorrectly label the bibliography tool biblatex, but that is wrong. If your editor actually runs BibTeX for you there would be no error with \bibliographystyle, because that is a valid combination. – moewe Apr 3 '17 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.