0

Long time lurker, first time poster, but my time has come.

I highly suspect the answer to my question is easy, but I can't find how to solve my problem. I'm typesetting my Ph.D. thesis and I'm using a template built by some students of my University. The default fonts of this template were changed to resemble a document made in Microsoft Word, for reasons I really don't comprehend (the default LaTeX font is so beautiful!).

I managed to revert the text back from Times New Roman to the default Computer modern Roman with a command

\renewcommand*\rmdefault{cmr}

But I couldn't find how to revert the math font to the default. Currently, for example, my equations are like this:

Equation with the "Microsoft-y" font

While I want them to be like this:

What I want

In my document I renamed the \vec{} command to produce boldface text instead of putting the small arrow. The second figure was produced with an online LaTeX formula editor because I just wanted a figure with the default math font.

The differences on both fonts are noted mainly in the greek letter tau and the roman letter u.

A MWE is as follows, without the several included packages. None of them are related to fonts, except amsmath is almost a default. The font is defined somewhere on the class ufscThesis.cls, which I'm not comfortable editing. I suspect it is possible to, on the document, globally redefine the math font in the same way I redefined the text font to CMR without touching on the class file.

\begin{document}
   \begin{equation}
       \rho\Delta\vec{u}=\vec{F}\tau
   \end{equation}
\end{document}

How do I do it?

  • Inside of the ufscThesis.cls there most likely are packages related to fonts included. You might open that and see what they did to change the font (just looking wouldn't hurt, would it?). – Skillmon Mar 28 '17 at 17:22
  • 2
    as @Skillmon says, math fonts have several interrelated settings and it's not so easy to set them all back (especially without knowing what changes have been made) better to edit a copy of the class and if (for example it has \RequirePackage{mathptmx} then simply comment out that line. – David Carlisle Mar 28 '17 at 17:24
  • @DavidCarlisle I should've made my comment longer but due to laziness... Thanks for completing it. – Skillmon Mar 28 '17 at 17:25
  • @Skillmon Sorry, I forgot to include that I tinkered with a copy of the class file and searched the whole document for font declarations, but there are none, not even the package mathptmx as DavidCarlisle suggested. However, this ufscThesis.cls is heavily based on the ABNTex (ABNT is the set of norms in Brazil) class, so I may have to look there. – Eduardo W. Mar 29 '17 at 18:26
  • Can you point to a source for the class? You probably can just disable the times option. – egreg Mar 29 '17 at 19:58
2

I solved it!

The class I'm using just configures a document according to ABNT rules (a Brazilian normatization organ), based on a LaTeX package called ABNTex (aptly named for ABsurd Norms for Tex). Since I found no mentions whatsoever about fonts on the class ufscThesis.cls, neither the modifications I did to force the default font worked, I decided to take a look on the class abnt.cls. There I found these lines:

%%%%%%    Opcao de fonte Times como romano default

\ifthenelse{\boolean{ABNTtimesfont}}% if `times'option enabled...
 {\IfFileExists{mathptmx.sty}%  try `mathptmx' first
   {\RequirePackage{mathptmx}}% 
    {\IfFileExists{mathptm.sty}% if not installed, try `mathptm'
       {\RequirePackage{mathptm}}%
       {\IfFileExists{times.sty} % 
         {\RequirePackage{times}}%
         {\renewcommand{\rmdefault}{cmr}}%
       }%
    }%
  \IfFileExists{helvet.sty}% including also Helvetica as sans serif.
    {\RequirePackage{helvet}}%
    {\IfFileExists{helvetic.sty}%
       {\RequirePackage{helvetic}}%
       {\renewcommand{\rmdefault}{phv}}%
    }%
  }%

It was just a matter of commenting this small snippet an, voilà, sexy beautiful equations again!

What I wanted from the start

Thanks for the help!!

  • I had a similar problem and your answer helped me. In my case, I only had to remove \RequirePackage{mathptmx} in the cls file. – Raphael Mar 2 '18 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.