I am a bit of a newbie with LaTeX. Everything was working well (mostly) but I am running into all sorts of weird errors since I added the siunitx package. The error log first showed errors with tables, which I was able to fix (I think) using a quick tip on entry (thank you). Now the remaining errors originate from all my figure captions. It feels like siunitx is trying to parse my figure captions but is rejecting their content. I tried the same strategy as what fixed it for my tables (\sisetup{parse-numbers = false}), but it is still not working. Any ideas?

This is my simple code (works if siunitx is commented out):

% Review cuthesis.sty for more documentation on available options
% for this package.
\usepackage[3committee,masters,standard,nonsequential]{cuthesis} %Carleton University template
%\usepackage{siunitx} %used for the writing of SI units such as micro
\usepackage{hyperref} %used for pdf properties




% Define thesis title and author
\dept{Systems and Computer Engineering}
\degreename{Master of Applied Science in Electrical Engineering}

% Specify your Thesis Submission Date
\submitdate{May, 2012} \copyrightyear{2012} \copyrightmonth{May}

% Thesis committee information for the signature page
% Be sure to specify size of committee in cuthesis options.
% Department Chair does not count as a committee member.
% ie: 1committee = department chair  (doesn't make sense)
%     2committee = firstcommittee + department chair
%     3committee = firstcommittee + secondcommittee + department chair
%     4committee = firstcommittee + secondcommittee + thirdcommittee + department chair
% Default setting is 1committee
\firstcommittee{Professor MS, Thesis Supervisor}
\secondcommittee{Professor MB, Examiner}
\thirdcommittee{Professor "Name", Thesis Co-supervisor}

% Specify department chair
\departmentchair{Professor HS, Chair,\\Department of Systems and Computer Engineering}

la la

  % Requires \usepackage{graphicx} 
  %TODO regenerate this graph with matlab
  \caption{Spectrum of a single modulated OFDM subcarrier (truncated).}  \label{fig:single}

  • 1
    You should provide a full working minimal example. I use siunitx and the caption package and in my very large documents with ~100 packages I have no problem. Nov 24 '11 at 21:21
  • Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. Nov 24 '11 at 21:21
  • In addition to a MWE, a full log would be useful: there was an issue some time ago with expl3 which had similar symptoms.
    – Joseph Wright
    Nov 24 '11 at 21:26
  • MWE posted above. Log is too big. How can I add it in a comment? What if I answer my own question?
    – Fred
    Nov 24 '11 at 21:58
  • @Fred That's not minimal: you load packages which I doubt cause the issue. Usually a log for a MWE will be fine for posting here. It is fine to answer your own question.
    – Joseph Wright
    Nov 24 '11 at 22:03

(This is a bit too long for a comment.)

If you work through to create a MWE, the problem can be isolated to a document consisting of





The calc package is entirely standard, so this is a bug in cuthesis.

(The problem shows up with siunitx as it loads calc.)

  • 1
    The incompatibility of cuthesis and calc was pointed out in caption works in one file but not another. Nov 24 '11 at 22:40
  • placing \usepackage{calc} at the top of my document, right before the \usepackage{cuthesis} works well as a workaround. It precedes the call to the same package in {siunitx}. Thanks everyone for the help!
    – Fred
    Nov 24 '11 at 23:47
  • @PeterGrill Good fine: This is probably a dupe, then
    – Joseph Wright
    Nov 25 '11 at 6:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.