1

So I am using MikTex on windows and I write and compile my code in Sublime Text 3. When I run the code without the bibliography it compiles just fine and I only have some small warnings:

file.tex:69: Package Fancyhdr Warning: \fancyfoot's `E' option without twoside option is useless on input line 69.
file.tex: destination with the same identifier (name{page.1}) has been already used, duplicate ignored

Those don't seem so bad, though I am not sure why they occur. But anyway the bigger problem is once I include my bibliography with "\bibliography{project.bib}" after compiling nothing happens. There is no error message, the console output in sublime text is just as before, but none of the changes I made in the document are seen in the pdf. The pdf simply is not updated. And even if I remove the bibliography afterwards it won't update anymore. I have to delete the auxilary files or whatever they are called. (file.aux, file.lof, file.out etc.) After deleting them and without the bibliography it compiles normally.

Now I also tried to compile it with TeXworks and here it doesn't finish compiling. Instead I get this message from the console:

[2] [3]
No file file.bbl.
[4]
("file.lof") [5] (file.aux) )
(see the transcript file for additional information){C:/Program Files/MiKTeX 2.
... [I skip a few lines here]
Output written on file.pdf (6 pages, 86351 bytes).
SyncTeX written on file.synctex.gz.
Transcript written on file.log. This is BibTeX, Version 0.99d (MiKTeX 2.9.6100 64-bit) The top-level auxiliary file: file.aux The style file: unsrt.bst I found no \citation commands---while reading file file.aux Database file #1: project.bib (There was 1 error message)

Sorry, but "C:\Program Files\MiKTeX 2.9\miktex\bin\x64\texify.exe" did not succeed.

The log file hopefully contains the information to get MiKTeX going again: /AppData/Local/MiKTeX/2.9/miktex/log/texify.log

You may want to visit the MiKTeX project page, if you need help.

The log file that it is pointing me to is empty. So not very helpfull. It says, that the .bbl file is missing. But I can't explain why. The bibliography is created correctly. My bib file only contains one entry, which is formatted correctly because I have used that entry before. Maybe there is some incompatibility issue between some of the packages I am using? I also tried to run an old document that definitely used to work, but I seem to have similar issues there.

--------------------------------------------------------

\documentclass[12pt]{report}

\usepackage[sc]{mathpazo}
\usepackage[T1]{fontenc} 
\linespread{1.05} 
\usepackage{microtype} 

\usepackage[hmarginratio=1:1,top=32mm,columnsep=20pt]{geometry}
\usepackage{multicol} 
\usepackage[hang, small,labelfont=bf,up,textfont=it,up]{caption} 
\usepackage{booktabs} 
\usepackage{float} 
\usepackage{hyperref} 

\usepackage{lettrine} 
\usepackage{paralist} 
\usepackage{graphicx}
\usepackage{abstract} 
\usepackage{textcomp}
\usepackage[noframe]{showframe}
\usepackage{framed}
\usepackage{listings}
\renewcommand{\abstractnamefont}{\normalfont\bfseries} 
\renewcommand{\abstracttextfont}{\normalfont\small\itshape} 
\usepackage{amsmath}
\usepackage{subcaption}
\usepackage[utf8]{inputenc}

\renewenvironment{shaded}{
  \def\FrameCommand{\fboxsep=\FrameSep \colorbox{shadecolor}}
  \MakeFramed{\advance\hsize-\width \FrameRestore\FrameRestore}}
 {\endMakeFramed}
\definecolor{shadecolor}{gray}{0.95}

\setlength{\parindent}{0cm}

\usepackage{titlesec} 
\renewcommand\thesection{\Roman{section}} 
\renewcommand\thesubsection{\Roman{subsection}}
\titleformat{\section}[block]{\large\scshape\centering}{\thesection.}{1em}{} 
\titleformat{\subsection}[block]{\large}{\thesubsection.}{1em}{}

\usepackage{fancyhdr}
\pagestyle{fancy}
\fancyhead{} 
\fancyfoot{} 
\fancyhead[C]{bulletin1  $\bullet$ bulletin2  $\bullet$ bulletin3} 
\headheight=15pt
\fancyfoot[RO,LE]{\thepage} 
\renewcommand*\rmdefault{ptm}
%----Title-------------
\title{\vspace{-15mm}\fontsize{24pt}{10pt}\selectfont\textbf{Title}} 

\author{
\large
\textsc{name}%\thanks{A thank you or further information}\\[2mm] 
\\
\normalsize Course \\
\normalsize Your institution\\

\normalsize Teacher: Teacher\\
\vspace{5mm}\\
\vspace{15mm}\\
}
\date{\normalsize \today}

\begin{document}

\maketitle % Insert title
\thispagestyle{fancy} % All pages have headers and footers
***content***
%\bibliography{project}
%\bibliographystyle{unsrt}
\end{document}

I hope I can avoid having to wipe and reinstall LaTeX.

closed as off-topic by Mensch, Henri Menke, Zarko, Troy, TeXnician Aug 10 '17 at 4:11

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Have you cited anything? It doesn't like the fact that there is nothing to put in the bibliography. If you compile on the command line, interactively, this will be easier to see. – cfr Mar 29 '17 at 0:18
  • Off-topic: load hyperref last. There is no point in setting a different header/footer for even pages in a single-sided document. – cfr Mar 29 '17 at 0:20
  • yes yes, I didn't put the actual content in here. It is mostly text and some tables, but I tried running it without the content and I have the same error. The references also pop up for the auto-completion. But when I compile it, it says citation undefined and when I compile it again afterwards it doesn't change anything anymore. – BlueScr33n Mar 29 '17 at 1:55
  • We need a minimal example which we can use to reproduce the problem. If the code you post doesn't have the problem or has a different one, what use is it? Take out the stuff you don't need to reproduce the problem and add enough to reproduce it. Compiling on the command line will give you more information. texify hides stuff from you. (Fine when all is well; less fine when it isn't.) Note that the error says the same: no citation commands found. So if you have them, they aren't making it into the .aux. Don't use .bib when you say \bibliography{<name>}. Put \bibliographystyle first. – cfr Mar 29 '17 at 2:03
  • 4
    I'm voting to close this question as off-topic because the op had too many commas in the authorlist, not showed in the question (see comments). – Mensch Aug 9 '17 at 22:56