1

I am trying to get the chapters of my document to start only on odd pages (that is, on the right; as good typsetting practices recommend). I have tried to use:

\documentclass[a4paper,openright,twoside]{report}

Of course, this achieves what I want, but it also changes the margins of even and odd pages. This is a behaviour I want to avoid. Therefore, I have tied to use the powerful geometry package to get margins as close as possible to normal (original) report margins. I do so by specifying the following line in the preamble (I know these are not exactly the report margins; but it's the closest I can get given I do not know how to specify exactly the original report margins with geometry):

\usepackage[top=4cm,bottom=4cm,left=4.5cm,right=4.5cm]{geometry}

However, this generates a strange behaviour. In short, when using the geometry package and specifying the margins I want, some pages change completely their layout. The document I am typesetting is full of theorems, definitions, examples and proofs; that I specify using mdframed. However, when loading geometry in the way I do it, some of the pages completely change their layout. That is, the spacing between mdframed environments becomes arbitrary too large in some pages. As you can guess, the issue is quite hard to reproduce with a MWE. Hence, I can provide no MWE this time (I am really sorry). What I can easily provide are two screenshots that show what I mean:

enter image description here

enter image description here

The first picture is what I get with \documentclass[a4paper,openright,twoside]{report} and \usepackage[top=4cm,bottom=4cm,left=4.5cm,right=4.5cm]{geometry}; the second picture is the original one with \documentclass[a4paper]{report} and no geometry. I guess that is easy to see that what I want is to avoid this rather strange vertical spacing behaviour of the first screenshot when loading geometry. Therefore, my questions boil down to:

Is there anyway of getting chapters to start only on right pages, yet having equal margins in all pages; without using the geometry package?

Or, alternatively:

Is there any way of using geometry such that I get what I desire without the layout of some pages changing as they currently do?

Thank you all in advance for your time. Any help or insight will be greatly appreciated.

PS1: I have found several related questions; but I do not think it is a duplicate.

PS2: Also, I am aware I can do this manually; but that means that I have to revise the setting every time I change the content of the document; which is not handy nor very LaTeX-style.

2
  • 1
    Are the mdframed elements breakable or floating? Otherwise, you can expect this spacing issues any time you change very small dimensions --- have just one line more in a paragraph and then all things have to be re-collocated and underfull vboxes will happen.
    – Rmano
    Commented Mar 29, 2017 at 10:31
  • Out of the four definitions that I have, two are breakable and two are not. In particular, definitions are not breakable. As far as I know, they are not floating. By the way, how can I make them floating? O: However, I'd expect LaTex to leave a lot of blank space at the end in a worst case scenario (which is what used to do without geometry), instead of re-spacing, which is what it does with geometry loaded.
    – EoDmnFOr3q
    Commented Mar 29, 2017 at 11:12

1 Answer 1

4

You could try to change the twoside switch later so that it doesn't affect the layout:

\documentclass[openright]{report}
\makeatletter\@twosidetrue\makeatother
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lipsum}
\begin{document}
\chapter{a}
\lipsum
\chapter{b}
\end{document}
1
  • Your solution works and generates the desired output. Hence, I happily accept it! Thank you.
    – EoDmnFOr3q
    Commented Mar 29, 2017 at 9:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .