2

I am creating the lay out for my girl's thesis, she wanted use Word and i can't accept that!

The thesis is a book translation, and I used reledpar to parallel original and translated text.

She needs the left pages to contain the original text, while the right page has to contain the translated text.

The pages on the left (the ones with original text) have not to count in page numbering, and this is achieved by the option sameparallelpagenumber. But then I have the same number printed on left and right pages, and I have to hide the left page number (i.e. I want page numbering printed only on the right-hand pages). I tried with \pagestyle{empty} but I don't know where to insert it into the reledpar environment ...

I also have to hide numbers in the blank pages created by prevpgnotnumbered.

This is an example of my code:

\documentclass[12pt,a4paper,twoside]{report}
\usepackage[italian]{babel}
\usepackage[utf8]{inputenc}
\usepackage[top=3cm, bottom=3cm, left=3cm, right=2.5cm]{geometry}
\usepackage{reledmac}
\usepackage[sameparallelpagenumber,prevpgnotnumbered,shiftedpstarts]{reledpar}
\linespread{1.5}
\usepackage{lipsum}

\begin{document}
\begin{pages}
\begin{Leftside}
\beginnumbering
\pstart
\lipsum
\pend
\endnumbering
\end{Leftside}
\begin{Rightside}
\beginnumbering
\pstart
\lipsum
\pend
\endnumbering
\end{Rightside}
\end{pages}
\Pages
\end{document}

Thanks!

  • Hi Luca. Welcome. I slightly edited your question, hopefully to make it clearer. I also removed the ebgaramond package, which won't be part of the problem or the solution! – Paul Stanley Mar 29 '17 at 10:14
  • Much better than my ... anything else! – Paul Stanley Mar 29 '17 at 10:18
1

For your first question, there is actually no way in reledpar to determine specifique page style for left or right page. In general, edition with only one number print the number for both side of a double page (for example, in the French series "Sources Chrétiennes"). However, you can use the fancyhdr package to tell to print nothing in the "even page" footter, that is left page footer.

\usepackage{fancyhdr}
\pagestyle{fancy}
\fancyfoot[CE]{}

For your second question, you can use prevpgstyle=empty option when loading reledpar.

  • The second tip works perfectly. The fancyhdr removed page numbers on left pages, but if i add a chapter with "\pstart[\chapter{Chapter 1}]", the page number is still showed oh the left page with the chapter. That commands also added the chapter name on the pahe headers, how can i remove that? Thanks! – Luca Mar 29 '17 at 11:04
  • that is not related to reledpar, but to the fact that `chapter` add footnotemark and have is own page style. Please open a new question about "how to suppress page number in chapter page" and "suppresse chapter name on page header" (or look on the search engine, there is answer). – Maïeul Mar 29 '17 at 11:09
  • Please also validate this answer. – Maïeul Mar 29 '17 at 11:09
  • @Luca did you find a solution? sorry to not answer you, but I think keeping question distincts is better – Maïeul Mar 30 '17 at 21:25
  • Yes, thanks! Before asking a new question i tried some solutions found in the web and it worked :) – Luca Apr 4 '17 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.