2

I have a problem with the acro-package and have not been able to find any answer or even anyone with the same problem. I am writing my thesis and since it is an area with a lot of abbreviations it is customary to have a list of abbreviations in the thesis. But when I use the acro-package everything except the writing of the list(e.g using \ac{some abbreviation} in the text). I have made a short test file just to make sure that it really is just the \printacronyms-command that does not work. The code is:

\documentclass{article}
\usepackage{acro}
\DeclareAcronym{udp}{
    short = UDP,
    long = User Datagram Protocol
}
\begin{document}
\printacronyms
testing if it is possible to print out the abbrivitions, e.g \ac{udp}
\end{document}

I get Three errors, namely:

!undefined Control sequence.\acro_sort_prop:NN...rop{##1}{##2}\seq_sort:Nn\I__acro_tmpa_seq{\int_co...
!Undefined Control sequence.<argument>\LaTeX3error:A sequence was misused.
!Undefined Control sequence.<argument>\sort_return_same:

I'm using TexMaker with pdfLaTeX. Tried to do it on a friends computer and it worked. Would rather see a solution where I don't need to use a different package or install some different software (e.g TexStudio..) since I've already produced quite a lot of text and I use the \ac{}-command a lot. I will be very grateful if somebody can help me. Thanks in advance!

closed as off-topic by moewe, gernot, CarLaTeX, Mico, Torbjørn T. Mar 30 '17 at 9:34

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    I could run your MWE without a problem. Maybe your packages are outdated. I have acro.sty 2017/01/22 v2.7a and expl3-code.tex 2017/03/18 v7019. Update your packages either via tlmgr (TeX live) or 'MikTeX Update' (MikTeX - in admin and user mode). – moewe Mar 29 '17 at 14:31
  • 1
    It could indeed be an update problem, like moewe says. The acro package has been updated on a frequent basis in the last few months (which is a good thing, as it's actively being developed). – thymaro Mar 29 '17 at 23:59
  • 1
    Thank you @moewe, after some updating it now works. Unfortunately i don't know which package actually caused the problem because the acro-package was up to date but the MikTex updater found a lot of packages that needed updating... :) – lillpelle Mar 30 '17 at 7:56
  • I suspect it was some LaTeX3 related package such as expl3 or xparse, but we can't be sure now. – moewe Mar 30 '17 at 8:01
  • 4
    I'm voting to close this question as off-topic because the problem was solved by updating the packages involved. – moewe Mar 30 '17 at 8:02

Browse other questions tagged or ask your own question.