0

I was installed MikTex and use it very well, however, I uninstalled it then download the last version of MikTex 2.9.5840, after the installation, many errors appear when compiling my .tex files. I tried to update the package (in case there is an important package not installed) and I got these messages:

  1. Error: Windows API error 87: The parameter is incorrect.

  2. Could not start Build & View:PdfLaTeX: pdflatex -synctex=1 -interaction=nonstopmode "<file name>".tex

  3. I got this error when trying to update MiKTeX using MiKTeX Update (Admin)

enter image description here

Finally, all the packages are installed and still my .tex files uncompilable. Did anyone have this problem before and how can you solve it?

Edit

I try to run update formats but for all formates it didn't update and give errors, here the error for pdflatex:

======================================================================

Unfortunately, the package miktex-latex could not be installed.Please check the log file:
C:/Users/MUHAMMAD/AppData/Local/MiKTeX/2.9/miktex/log/miktex-makefmt.log
======================================================================

Sorry, but miktex-makefmt did not succeed for the following reason:

The input file could not be found.

The log file hopefully contains the information to get MiKTeX going again:

C:/Users/MUHAMMAD/AppData/Local/MiKTeX/2.9/miktex/log/miktex-makefmt.log

You may want to visit the MiKTeX project page, if you need help.

Sorry, but "MiKTeX Configuration Utility" did not succeed.

The log file hopefully contains the information to get MiKTeX going again:

C:/Users/MUHAMMAD/AppData/Local/MiKTeX/2.9/miktex/log/initexmf.log

You may want to visit the MiKTeX project page, if you need help.
  • There are already questions about "API error 87". – Schweinebacke Mar 30 '17 at 16:32
  • I read a lot about this problem and it seems for the first error that pdflatex is running so I close it and this error never appear again, but I can't find a solution for the remaining errors. – Muhammad Abdulrasool Mar 30 '17 at 16:42
  • If the formats could not be build while MiKTeX installation you have to build them using MiKTeX Settings. – Schweinebacke Mar 30 '17 at 16:48
  • Why did you deinstall miktex if everything was working? Close everything miktex related (YAP, texworks, whatever). Open the package manager (admin), synchronize and then install all packages with a miktex in their name. Open the update manager and check for updates. Then test pdflatex on a command line, not in your editor. – Ulrike Fischer Mar 30 '17 at 16:51
  • @UlrikeFischer - I did all that, but I didn't test pdflatex on a command line, I write pdflatex in command and it returned this "This is pdfTex, Version 3.14159265-2.6-1.40.17 <MiKTex 2.9.6210 64-bit> – Muhammad Abdulrasool Mar 30 '17 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.