10

I'm having 2 problems with references in my thesis. First when a last name starts with letter W, it always comes at the top. Before A. But if I change the authors lastname from Wolf to Solf it works. W isn't a special character in this context... or is it?

Second problem is when I have two names like 'Ivan and Me', in the references list I get 'Ivan, A and B Me' not 'Ivan, A and Me, B'. Does anyone have any suggestions? Thanks in advance.

My mwe is:

\documentclass[12pt,a4paper,swedish]{report}
\usepackage[latin1]{inputenc}
\usepackage[swedish]{babel}
\usepackage[style=authoryear,natbib=true,backend=biber,sorting=nyt]{biblatex} 
\addbibresource{incl/tgene.bib} 
\begin{document}
Foo \parencite{ivan} bar \parencite{wolf}.
\printbibliography[heading=bibintoc]
\end{document}

And my .bib looks like:

 @book{ivan,
    author = {Ivan, A and Me, B},
    title = {Title A},
  }
  @book{wolf,
  author={Wolf, Ceasar},
  title={Title B},
  }
4
  • 3
    Welcome to TeX.SE! I am able to fully reproduce the issue you've encountered. There appears to be a rather unfortunate interaction (definitely a bug!) between (a) babel being loaded with the option swedish and (b) biblatex being loaded with the option backend=biber. As a temporary work-around until a bug fix becomes available, you may want to change the option backend=biber to backend=bibtex. (Assume that not using babel with the option swedish is not an option for you...)
    – Mico
    Mar 30 '17 at 17:03
  • On the name point, you just need \DeclareNameAlias{sortname}{given-family} in the preamble. The bug, I'm afraid, I can't help with. Mar 30 '17 at 17:15
  • Thanks all for quick response and information. Mico: Bibtex did the trick. It even solves the potential problem with swedish letters first in last-name. With regards to the 'Ivan and Me' - naming. If i group the names with {} like author = {{Ivan, A} and {Me, B}} I get 'Ivan, A och Me, B (2014)' just like I needed.
    – Titan72
    Mar 30 '17 at 17:45
  • 1
    I have written an 'answer' with more examples, can you please test them and also tell us which OS you use?
    – moewe
    Mar 31 '17 at 6:54
6

With your MWE I get the desired sorting of 'Ivan' first, 'Wolf' last. I'm using biblatex 3.7/Biber 2.7 on Windows 10 (via MikTeX). But there are different issues.

First of all, I could get back the desired sorting by passing

sortlocale=sv-SE_reform

to the biblatex loading options.

You ask if 'W' is special, and according to Wikipedia it is!

The letter 'W' is rare. Before the 19th century, 'W' was interchangeable with 'V' ('W' was used in Fraktur, 'V' in Antiqua). [...] Swedish sorting traditionally and officially treated 'V' and 'W' as equivalent, so that users would not have to guess whether the word, or name, they were seeking was spelled with a 'V' or a 'W'. The two letters were often combined in the collating sequence as if they were all 'V' (or all 'W'), until 2006 when the 13th edition of Svenska Akademiens ordlista. By 2006, 'W' had grown in usage because of new loanwords, so 'W' officially became a letter, and the 'V' = 'W' sorting rule was deprecated. Pre-2006 books and software generally use the rule (unless the authors did not know about or chose not to implement this unusual rule). After the rule was deprecated, some books and software continued to apply it. [...] (The Swedish Academy's Orthographic Dictionary) declared a change.

So before 2006 'V' and 'W' were to be treated as equivalent when sorting, and from 2006 onwards as two different characters (from Wikipedia I take it that 'W' would sort directly after 'V').

I have notified the Biber developer https://github.com/plk/biber/issues/164

On Github, a commenter points out that things are never as easy as they seem from a two-minute survey of the Wikipedia article. Apparently both schemes currently co-exist. And what's worse some rules seem to favour name sorting using the old scheme, but the new scheme for all other words.

When I cite the following three items without the sortlocale option

@book{vn,
    author = {Vn, A},
    title = {Title VN},
}
@book{vr,
    author = {Vr, A},
    title = {Title VR},
}
@book{wolf,
  author={Wolf, Ceasar},
  title={Title B},
}

I obtain

Vn, A (n.d.). Title VN.

Wolf, Ceasar (n.d.). Title B.

Vr, A (n.d.). Title VR.

Which according to post-2006 rules is incorrect, but follows the pre-2006 rules.

2

Here's a hack to work around the bug with Swedish: use the sortkey field to force the entry after V. Maybe other letters need a similar treatment. :-)

\begin{filecontents*}{\jobname.bib}
@book{ivan,
    author = {Ivan, A and Me, B},
    title = {Title A},
}
@book{wolf,
  author={Wolf, Ceasar},
  title={Title B},
  sortkey={VVVVVVVolf},
}
\end{filecontents*}

\documentclass[12pt,a4paper]{report}
\usepackage[latin1]{inputenc}
\usepackage[swedish]{babel}

\usepackage[style=authoryear,natbib=true,backend=biber,sorting=nyt]{biblatex}
\usepackage{csquotes}

\addbibresource{\jobname.bib} 
\DeclareNameAlias{sortname}{given-family}

\begin{document}

Foo \parencite{ivan} bar \parencite{wolf}.

\printbibliography[heading=bibintoc]

\end{document}

I used the filecontents* environment just for making a self-contained example.

enter image description here

2
  • I take it you got the undesirable sorting of 'Wolf' first on a Mac? Can you confirm that? On my Windows machine 'V' and 'W' are equivalent, thus 'Wolf' sorts last, but still not correctly.
    – moewe
    Mar 31 '17 at 6:55
  • @moewe Yes, confirmed.
    – egreg
    Mar 31 '17 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.