1

This question already has an answer here:

My TeXShop has been acting out: I haven't been able to open files with it. I was able occasionally to open document class files, but I had no luck whatsoever with beamer files. I can open and compile all the files using TeXMaker. I've tried reinstalling the entire MacTeX package twice but the problem persists (I'm using the latest TeXShop and the latest Sierra on Mac). Someone from comp.text.tex suggested that I need to find and remove TeXShop's configuration file, but I don't know how. Any help would be appreciated.

marked as duplicate by Alan Munn, clemens, Schweinebacke, Stefan Pinnow, gernot May 4 '17 at 15:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I am not a OS-X-Expert, but have you clicked on a single TeX-file and then clicked 'cmd'+'i' and set the open option to TeXShop? – CampanIgnis Apr 3 '17 at 13:40
  • 1
    What do you mean by "unable to open files"? Do you mean double clicking on them from within the Finder, or can you not open a file even if you choose "Open" from the file menu within TeXShop and then navigate to the file? If it's the former, you should try what @CampanIgnis suggests. If it's the latter, then you should perhaps reinstall TeXShop (not MacTeX) by deleting the application (inside the TeX folder in Appplications) and also deleting ~/Library/TeXshop (get to it via the Go menu in the Finder.) – Alan Munn Apr 3 '17 at 15:54
  • Sorry I wasn't being clear: when I double-clicked a beamer file, for example, then the file wouldn't open and I would get the eternal rainbow circle of death (which means that the computer is trying to load the file but just stuck in the process forever). I tried already the cmd+i. Will try reinstalling TexShop and report back here. Many thanks! (Hopeful here.) – Emil Apr 4 '17 at 0:36
  • Nope, still doesn't work. I reinstalled the TeXShop after deleting the application and the ~/Library/TeXShop. Please help! – Emil Apr 4 '17 at 1:28
0

I just came across your very same problem: remove \usepackage{pstricks}, if you had it before: after the update, it drives beamer crazy...I hope this helps. Otherwise look by exclusion for packages having a similar effect. Good luck.

Mirko

  • Wow, thanks very much! It finally worked. Should we report this to pstricks developers? – Emil Apr 4 '17 at 14:33
  • @emil This is a problem with Apple's PDFKit, not really with TeX. We'll close your question as a duplicate (see link in last comment on your question.) – Alan Munn May 4 '17 at 14:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.