3

I am creating an ePub like this:

pandoc test.tex --latex-engine=xelatex -o e.epub --bibliography=works-cited.bib -f latex -t epub3+footnotes

However, instead of getting footnotes like this in the ebook reader:

This is some text1

I am getting this:

This is some text.(Author 2004, 40)

Having spent an hour on the pandoc site, I can't find an option to change this, what am I missing?

UPDATE: It appears something like autocite=footnote may impact the output, but I have not worked out a way to get this to work at this point. I am currently trying:

\usepackage[style=sbl,backend=biber,autocite=footnote]{biblatex}

4

If you have a file test.tex like this:

% !TeX program = XeLaTeX

\documentclass{article}
\usepackage[style=sbl,backend=biber,autocite=footnote]{biblatex}
\addbibresource{works-cited.bib}

\begin{document}
This is some text.\autocite{Author2004}

\printbibliography
\end{document}

And a bibliography called works-cited.bib:

@BOOK{Author2004,
    AUTHOR = {Author},
    YEAR = {2004},
    TITLE = {Title},
}

Then you will get a pdf like that:

enter image description here


To convert this input to .epub with pandoc you need a csl file that supports notes like chicago-note-bibliography.csl.

Since pandoc uses no latex engine to convert to epub it ignores all latex options, but you have to specify the csl file you've downloaded earlier with the option --csl instead.

Runningpandoc with the following options will suffice:

pandoc test.tex --bibliography=works-cited.bib --csl=chicago-note-bibliography.csl -t epub3+footnotes -o e.epub

Result:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.