(Not really a duplicate, got some errors that wasn't in the previous guide) Help using MathTime Pro 2 fonts in Ubuntu Linux with tex-live

What I have done: 1. Extracted the contents of the mpt2fonts.zip.tpm into a folder called mathtime.

  1. Moved the contents of mathime into /usr/local/share/texmf, using sudo mv mathime/* /usr/local/share/texmf

  2. Then did the following sudo texhash sudo updmap-sys --disable mt-belleek.map --nomkmap sudo updmap-sys --disable belleek.map --nomkmap sudo updmap-sys --disable mt-yy.map --nomkmap sudo updmap-sys --disable mt-plus.map --nomkmap sudo updmap-sys --enable Map mtpro2.map sudo chmod -R a+r+x /usr/local/share/texmf/

  3. I then verified that $(kpsewhich updmap.cfg) contained the line Map mtpro2.map, which it did.

However, I get the error

! LaTeX Error: File `mtpro2.sty' not found.Type X to quit or to proceed,or enter new name. (Default extension: sty)Enter file name:! Emergency stop. \usepackage


!==> Fatal Error (...) No PDf produced

How do I proceed? Thanks in advance

EDIT> since i wrote this up, I have also ran mktexlsr, which did not help

  • If mtpro2.sty isn't found then it either doesn't exist, or is in the wrong folder, or you didn't update the file name database (run mktexlsr). – Ulrike Fischer Apr 4 '17 at 14:58
  • How can I check if it doesn't exist or is in the wrong folder? I ran mktexlsr, it didn't help. – Kenneth Ravn Apr 4 '17 at 15:12
  • Search for it and tell us in which folder it is. – Ulrike Fischer Apr 4 '17 at 15:13
  • You didn't say you ran mktexlsr in your description. – cfr Apr 4 '17 at 15:17
  • @cfr, I didn't say it since I didn't know it. I tried it after Ulrike Fischer said it. – Kenneth Ravn Apr 4 '17 at 15:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.