4

I have been using beamer in LyX for a while now. Love it. But I just got a new computer, istalled LyX again and when I create a new beamer file (or open an old one) the "separator" option that is used to end a frame is not avaiable.

I do not know if there is something wrong with my installation or if I should install some package, or something else.

Has anybody ever run into this problem as well?

Thank you for the help.

Edited: Thank you for the answers, I basically need to update lyx on the other computers now.

4

Pressing Enter in an empty line of the standard environment inserts a separator (from LyX 2.2.2 upward).

  • Simple, direct and worked perfectly. Thanks – Gustavo Amarante Apr 3 '18 at 14:37
4

Simply you have changed the version of LyX. The change was fuzzy as there are no more Separator nor FrameEnd options of the previous versions in the pull-down box at the left end of the toolbar, but you can use Edit > Start new environment (Frame) or the shortcut Alt + PEnter.

This will split the frame in two frames (or it start a new one when the cursor is at the end of the frame) but note that this option might be not available if you have the cursor in the wrong place (e.g: inside the frame title) or it will change to start another environment (e.g.: to Start new environment (Enumerate), if you have actually the cursor inside a numbered list), so the shortcut not necessarily will produce the expected result.

  • I can no longer make this work in lyx 2.2.3. The separator is gone from the list. Before in 2.2.x, I would hit (on mac) ctrl+p+space and then type separator. It's no longer there. – Superpronker Jan 16 '18 at 6:37
  • @Superpronker I prefer edit Beamer presentations in plain LaTeX/text editors. IMHO how LyX manage frames if one of the least successful aspect of the program. It could be nice if the program handled frames just as minipages or floats, where there are not start without end, it's always clear where they start and end, they can be closed, and is clear if something is between or within that boxes. – Fran Jan 16 '18 at 7:24
  • It's not like riding a ferrari, but neither is plain latex. Beamer is clunky. FYI, the "solution" was ctrl+enter... sometimes(!) – Superpronker Jan 17 '18 at 7:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.