1

I'm having trouble loading the noto font package.

(I'm using Texmaker on Windows 7, if that makes any difference.)

When I compile the following:

\documentclass[a4paper]{article}
\usepackage[margin=1in]{geometry}
\usepackage{lipsum}
\usepackage{noto}
\begin{document}
\lipsum
\end{document}

I get the error message "LaTeX Error: File `noto.sty' not found." in LaTeX, PDFLaTeX, XeLaTeX and LuaLaTeX, but when I compile:

\documentclass[a4paper]{article}
\usepackage[margin=1in]{geometry}
\usepackage{lipsum}
\usepackage{mathspec}
\setallmainfonts{Noto Serif}
\begin{document}
\lipsum
\end{document}

Using only XeLaTeX and LuaLaTeX, there is no error since I do have the fonts installed locally.

I'm able to load other new packages so there's nothing wrong with Texmaker or MiKTeX.

Does anyone have a solution to this problem?

closed as off-topic by egreg, Stefan Pinnow, CarLaTeX, Zarko, gernot Apr 8 '17 at 14:33

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Is the package visible in the package manager from Miktex? And I don't think that the question is specific to Texmaker, so you could rename the title of the question. – Dr. Manuel Kuehner Apr 6 '17 at 21:19
  • It doesn't seem to be visible in MiKTeX's package manager, no. Perhaps I've mislead you with my use of the word "load" in my question; what I really mean is "install". – Miztli Apr 6 '17 at 21:26
  • 1
    Synchronize the package database (menu repositories in the package manager) – Ulrike Fischer Apr 6 '17 at 21:28
  • 1
    I made a video tutorial (1:25 min) how to install a package under MiKTeX: youtube.com/watch?v=OD15rZO_rD8 – Dr. Manuel Kuehner Apr 6 '17 at 23:17
  • 4
    I'm voting to close this question as off-topic because the issue was due to not having maintained the MiKTeX installation – egreg Apr 8 '17 at 11:15
0

As @Ulrike Fischer commented, this issue was solved by synchronising the package database in MiKTeX's package manager (an option available in the repositories menu). The problem seems to have been that noto was packaged after I had installed MiKTeX on my computer and the database had not been synchronised since.

Not the answer you're looking for? Browse other questions tagged or ask your own question.