3

I am writing a report and want to have roman numerals numbering the pages prior to my Introduction section. I have the following:

\begin{document}

\pagenumbering{gobble}

\input{Chapters/titlePage}

\pagenumbering{roman}

\chapter*{\centering Executive Summary}
\input{Chapters/executiveSummary}

\newpage
\tableofcontents
\listoffigures
\listoftables

\chapter{Introduction} %I want the first page of my introduction chapter to
                       %count as page one of my document but not be displayed. 
                       %However, I would like to display the second page with 
                       %arabic numbering.
\input{Chapters/introduction}

The issue I have is I don't know how many lines in my LaTeX code will fit on the first page, so I can't just use

\pagenumbering{gobble}> and then \pagenumbering{arabic}>

One solution I have thought of is just putting the text in and figuring out how many lines are used before a new page is created, then implementing the page numbering there, but it seems that there must be an alternative that is modular.

Thanks!

Note: Document class is report.

  • 2
    it is very hard to understand your problem description, please fix the example so people can run it and see the issue. – David Carlisle Apr 6 '17 at 21:33
  • 2
    but perhaps you just want to ammend the definition of \chapter to use \thispagestyle{empty} instead of its default \thispagestyle{plain} (you could use fancyhdr package for example – David Carlisle Apr 6 '17 at 21:35
  • To clarify, I have a Title Page, an Executive Summary page, and pages for my TOC, LOF, and LOT. Following this, I have an Introduction section, the first page of which should count as page number 1 in my document (using arabic numbering). However, I only want to start displaying page numbers on page 2. I haven't given it a try yet, but I think Werner's answer below will give me what I need. – jmd17 Apr 6 '17 at 21:40
4

You can use \thispagestyle{empty} right after the first \chapter command.

Here is the usage:

                \documentclass[]{report} 
                \usepackage{lipsum}
                \begin{document}
                \chapter{introduction}
                \thispagestyle{empty}
                \lipsum
                \end{document}

Which produces:

enter image description here

on the first page of the introduction, and:

enter image description here

from the second on

  • 1
    Your use should be \lipsum[1-15], not \lipsum{15}. – Werner Apr 6 '17 at 21:41
  • @barbarabeeton yup! mistake of mine. I'll promptly correct it, thanks – Moriambar Apr 6 '17 at 21:41
0

This is what page styles are for since they are bound to the page, rather than the numbering.

You want some specific chapter's first page to behave differently from other pages within your document, so create a specific chapfirstpage style using fancyhdr (or use empty if you just want it blank):

enter image description here

\documentclass{report}

\usepackage{fancyhdr,lipsum}
\fancypagestyle{chapterfirstpage}{%
  \fancyhf{}% clear header/footer
  \renewcommand{\headrulewidth}{0pt}% Remove page header rule
  %\renewcommand{\footrulewidth}{0pt}% Remove page footer rule (default)
}

\begin{document}

% ... more document content

\clearpage
\chapter{A chapter}
\thispagestyle{chapterfirstpage}% ...or \thispagestyle{empty}
\pagenumbering{arabic}
\lipsum[1-50]

% ... more document content

\end{document}

Note that the page style is set to chapterfirstpage (or empty) after \chapter, since \chapter itself executes \thispagestyle{plain} (by default).

  • What is the difference between this and @Moriambar 's response? – jmd17 Apr 6 '17 at 21:43
  • @jmd17: I added some explanation as to the placement of \thispagestyle, as well as an option of defining your own (different) style based on using fancyhdr. – Werner Apr 6 '17 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.