2

I'm trying to get ltx2any running with TexStudio under Windows 10. I have ltx2any installed in "D:\Programs\Office\Latex\ltx2any", and put the folder in the PATH environment. Running "ltx2any" on a *.tex file in a command prompt works fine. However, if I try to configure a user command in TexStudio, such as

"D:/Programs/Office/Latex/ltx2any/ltx2any" -synctex -c %

I just get the following error:

Error: Could not start the command: "D:/Programs/Office/Latex/ltx2any/ltx2any" -synctex -c "file"

I've tried various versions of the user command, with and without the path to the file, or pointing it to ltx2any.rb, but none of these seem to allow me to run ltx2any from within TexStudio. Does anybody have any helpful tips for how to resolve this?

  • 1
    I don't use ltx2any but is there no file extension? – Dr. Manuel Kuehner Apr 7 '17 at 0:21
  • Indeed there isn't, but the version with an extension produces the same error: > "D:/Programs/Office/Latex/ltx2any/ltx2any" -synctex -c %.tex So it seems to be about calling ltx2any, not about pointing it to the right file. – humidz Apr 7 '17 at 0:26
  • 1
    Can you run ltx2any directly in the folder using the command window? – Dr. Manuel Kuehner Apr 7 '17 at 0:29
  • Yes, I can, but having to run it manually every time instead of using a shortcut within TexStudio would kind of defeat the purpose. :) – humidz Apr 7 '17 at 0:30
  • I just asked to be sure that is works in general, nothing more. – Dr. Manuel Kuehner Apr 7 '17 at 0:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.