4

I use Zotero for my manage my bibliography. Zotero lets me export my library in both BibLateX and BibTeX formats. There is not much difference between them, however, I did notice that it exports the year for a given reference differently.

If I have specified the exact date for a reference, e.g., 1991-09-01, exporting in "biblatex" format includes the full date, whereas, in BibTeX format, it includes the year and month separately, and excludes the day (see below):

BIBLATEX
@article{mysampleref_1991,
    [...]
    date = {1991-09-01},
    langid = {english}
}

BIBTEX
@article{mysampleref_1991,
    [...]
    month = sep,
    year = {1991},
    pages = {339--354}
}

Now, as such, that is not a problem. However, according to APA, a standard journal article in the Bibliography should only show the year (not the full date, with month and day) after the author.

I use biblatex-apa in my preamble as follows:

\usepackage[style=apa, sortcites=true]{biblatex}
\DeclareLanguageMapping{british}{british-apa}
\addbibresource{reflib.bib}

If I import my bib file with the biblatex formatted bib file, which has the full date, the reference in my bibliography will also show the full date (see screenshot below). I am surprised by this behaviour as I would have thought that biblatex-apa would automatically suppress the full date and only show the year, but it does not. I have to additionally specify in the package options labeldate=year to make sure only the year appears. Surely, biblatex-apa would adhere to standard APA by default?

enter image description here

As requested here a basic MWE:

\documentclass[12pt, a4paper]{memoir}
\usepackage[utf8]{inputenc}
\usepackage[british]{babel}
\usepackage[style=apa, sortcites=true]{biblatex}
\DeclareLanguageMapping{british}{british-apa}
\addbibresource{biblatex.bib}
\begin{document}
Just a basic test of some an APA reference \cite{wheeler_self-recording_1991}.
\printbibliography
\end{document}

and here the contents example of the exported bibliography from Zotero in biblatex-format (biblatex.bib)

@article{wheeler_self-recording_1991,
    title = {Self-recording of everyday life events: origins, types, and uses},
    volume = {59},
    issn = {1467-6494},
    url = {http://onlinelibrary.wiley.com/doi/10.1111/j.1467-6494.1991.tb00252.x/abstract},
    doi = {10.1111/j.1467-6494.1991.tb00252.x},
    shorttitle = {Self-Recording of Everyday Life Events},
    abstract = {Some abstract text},
    pages = {339--354},
    number = {3},
    journaltitle = {Journal of Personality},
    author = {Wheeler, Ladd and Reis, Harry T.},
    urldate = {2017-04-07},
    date = {1991-09-01},
    langid = {english}
}
  • 1
    Which versions of biblatex and the APA style are you using? Can you also give a complete MWE we can try? It is possible that you are using an older version of the style from before this issue was fixed. – PLK Apr 8 '17 at 14:34
  • 2
    @plk I can replicate this with the most recent versions of biblatex (3.7) and biblatex-apa (7.4). The language mapping (american or british doesn't matter either.) – Alan Munn Apr 8 '17 at 18:39
  • 1
    You have to ping people with an at symbol e.g. @PLK. – cfr Apr 8 '17 at 21:17
  • 1
    But you can only ping one person per comment, so @AlanMunn must be pinged in a new comment. – cfr Apr 8 '17 at 21:17
  • 1
    thanks @cfr, learned something new and guess you pinged them for me in that case :) – Tina Apr 8 '17 at 21:41
1

This is fixed in version 7.5 but it's not released yet. As a workaround for now, you can add this to your preamble:

\AtEveryCite{%
  \clearfield{labelmonth}%
  \clearfield{labelday}%
  \clearfield{labelendmonth}%
  \clearfield{labelendday}%
}
  • 1
    We will probably have to wait for the OP to confirm that, but I think she also wants the month and day gone in the bibliography. – moewe Apr 10 '17 at 10:06
  • Given what I could find at research.moreheadstate.edu/c.php?g=107001&p=695198 and probably more importantly blog.apastyle.org/apastyle/2010/01/… maybe you could automate month day deletion for most types except for the exceptions listed in the links. – moewe Apr 10 '17 at 10:15
  • 1
    BTW: Regardless of what was actually wanted, don't you need \AtEveryCitekey in order to access entry fields? Deleting fields in \AtEveryCite should not work. – moewe Apr 10 '17 at 16:25
  • 1
    @Tina Of course not, \AtEveryCitekey is still for citations. For the bibliography you would need \AtEveryBibitem instead. – moewe Apr 11 '17 at 8:11
  • 1
    @Tina Actually, I would use labeldate=year. There is one catch with that though, the links in my comment above indicate that in a few rare cases the APA wants to see full dates. With labeldate=year it is hard to get the full date back, while with the \clearfield approach it is easy to do that conditionally on entry type or something else. – moewe Apr 11 '17 at 9:10
0

I just got this issue when I updated biblatex (3.9) and biblatex-apa (7.5) with Miktex on Windows 10. For the bib entries I use Zotero with BBLatex export tool.

I used to have the date= year package option and :

\AtEveryBibitem{\clearfield{month}}
\AtEveryBibitem{\clearfield{day}}

Replacing month by labelmonth and day by labelday solved the problem. It is confusing as month and day are not fields in the bib entry.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.