16

I need to set a piece of my \institute name in small caps in my beamer presentation.

Now I set:

\institute{Dipartimento di Tecnologie dell'Infomazione \\ Corso di Laurea 
  in: {\scshape Sicurezza dei Sistemi e delle Reti Informatiche}}

but the small caps setting is completely ignored. Same for \textsc{}

Any clue?

1
  • 1
    Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. A tip: If you indent lines by 4 spaces or enclose words in backticks `, they'll be marked as code, as can be seen in my edit. You can also highlight the code and click the "code" button (with "{}" on it).
    – egreg
    Nov 27, 2011 at 17:23

3 Answers 3

24

The small caps command has not the desired effect if your font doesn't provide a small caps shape. If necessary, switch to a font family which supports it. Here's an example showing that it works with \rmfamily:

\documentclass{beamer}
\title{A sample document}
\subtitle{for demonstrating small caps in an institute name}
\author{Author}
\institute{Dipartimento di Tecnologie dell'Infomazione \\
  Corso di Laurea  in: {\rmfamily\scshape Sicurezza dei Sistemi e delle
  Reti Informatiche}}
\date{\today}
\begin{document}
\maketitle
\end{document}

institute on title page with small caps

So the solution is, choose another font or at least another font weight, family or shape of which there's a small caps variant.

4
  • Aren't you missing something before \scshape?
    – egreg
    Nov 27, 2011 at 20:24
  • @egreg That line is a copy of the code in the OP's question. We could insert \rmfamily before \scshape, as there's no sans serif small caps shape here. Though LaTeX switches for us, I added \rmfamily to be on the safe side.
    – Stefan Kottwitz
    Nov 27, 2011 at 20:30
  • i am using this theme blog.barisione.org/2007-09/… setting \institute{Dipartimento di Tecnologie dell'Infomazione \\ Corso di Laurea in: \\{\rmfamily \scshape Sicurezza dei Sistemi e delle Reti Informatiche}} the small caps works
    – remix_tj
    Nov 27, 2011 at 21:45
  • This does not work for me, sadly.
    – Translunar
    Mar 31, 2015 at 19:53
1

add \usepackage{lmodern} in the preambula. This is about latinmodernroman: http://www.tug.dk/FontCatalogue/latinmodernroman/

1

I just came to this question and answer and think that the following link to the LaTeX Font Catalogue could be a good source for looking at fonts with small caps (or other demands): See therefore: https://tug.org/FontCatalogue/ for browsing and searching in it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .