13

As in apa6e and biblatex-apa I'm trying to use apa6e and biblatex-apa together and having problems.

Before I arrived at these problems, over the course of many hours of much reading, I first managed to get BibTeX working as expected in a simple input file (by modifying sample2e.tex). Then I managed to get apa6e working as expected based on the author's example in apa6e.pdf (which uses apacite). But when I try to get apa6e working with biblatex-apa, I end up with problems.

Here's my input file:

\documentclass{apa6e}

\usepackage[american]{babel}
\usepackage{csquotes}

% biblatex
\usepackage[style=apa]{biblatex}
\bibliography{biblatex-apa-test-references}

\title{An Example Document}
\shorttitle{Psychology: the end}
\author{Silly Name} 
\authornote{\dots}
\abstract{\dots}

\begin{document}

\maketitle

This is an example input\cite{7.01:2} file.  Comparing it with
the output it generates can show you\cite{7.01:3a} how to
produce a simple document of your own.

\printbibliography

\end{document}

Attempting to typeset this in TeXShop by running LaTeX, then BiBTeX (which based on console messages, does seem to correctly call biblatex rather than BiBTeX), then LaTeX again, I get the following error message which I am having great difficulty (no doubt due to my lack of experience with TeX and co.) decoding.

(./test6.aux) (/usr/local/texlive/2011/texmf-dist/tex/latex/psnfss/ot1ptm.fd)
*geometry* driver: auto-detecting
*geometry* detected driver: pdftex
(./test6.bbl)
Underfull \hbox (badness 10000) in paragraph at lines 18--18
 []\OT1/ptm/m/n/12 An Ex-am-ple Doc-u-ment 

Underfull \hbox (badness 10000) in paragraph at lines 18--18
 []\OT1/ptm/m/n/12 Silly Name 

Underfull \hbox (badness 10000) in paragraph at lines 18--18
 []\OT1/ptm/m/n/12 Author Note 
[1{/usr/local/texlive/2011/texmf-var/fonts/map/pdftex/updmap/pdftex.map}]
Underfull \hbox (badness 10000) in paragraph at lines 18--18
 []\OT1/ptm/m/n/12 Abstract 
[2]
Underfull \hbox (badness 10000) in paragraph at lines 18--18
 []\OT1/ptm/m/n/12 An Ex-am-ple Doc-u-ment 

Underfull \hbox (badness 10000) in paragraph at lines 25--25
 []\OT1/ptm/b/n/12 References 
./test6.tex:25: Undefined control sequence.
<argument> \mkbibdateapalongextra 
(/usr/local/texlive/2011/texmf-dist/tex/latex/psnfss/ot1pcr.fd)
(/usr/local/texlive/2011/texmf-dist/tex/latex/psnfss/ot1ztmcm.fd)
(/usr/local/texlive/2011/texmf-dist/tex/latex/psnfss/omlztmcm.fd)
(/usr/local/texlive/2011/texmf-dist/tex/latex/psnfss/omsztmcm.fd)
(/usr/local/texlive/2011/texmf-dist/tex/latex/psnfss/omxztmcm.fd)
Overfull \hbox (8.03372pt too wide) in paragraph at lines 25--25
[][]  \OT1/ptm/m/n/12 Gilbert, D. G., Mc-Cler-non, J. F., Ra-bi-novich, N. E., 
Sugai, C., Plath, L. C., As-gaard, G., ... Botros, 
./test6.tex:25: Undefined control sequence.
<argument> \mkbibdateapalongextra 
                                  {year}{month}{day}\iffieldundef {endyear}{...
l.25

I tried many different sources in several different *.bib files before eventually trying the .bib database shown above and included with biblatex-apa. All trials gave a similar error.

Can someone help? I'm impressed that the poster above was able to do anything with apa6e and biblatex-apa, and if I only had her problem of having the reference page title show up in bold, I'd be really happy.

If you need to know, my tools are from a fresh installation of MacTeX that I immediately updated using the TeX Live Utility. I've checked my versions for apa6e (v0.3) and biblatex-apa (v4.2), and I think these are current.

  • Welcome to TeX.sx! Usually, we don't put a greeting or a "thank you" in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Upvoting is the preferred way here to say "thank you" to users who helped you. – Torbjørn T. Nov 27 '11 at 21:18
  • Thanks for the feedback (oops... is that another faux pas? sheesh...). I'll try to remember that. FWIW, I'm not yet in a position to upvote anyone based upon my reputation which is apparently less than 15 at the moment. – TeXnewbie Nov 27 '11 at 21:26
  • No problem, it's not a big deal. – Torbjørn T. Nov 27 '11 at 22:07
14

The problem with your sample document is that you are missing the line

\DeclareLanguageMapping{american}{american-apa}

This should appear after you have loaded biblatex.

If you are still having problems with your sample document, the following sample document works correctly with a standard MacTeX/TeXShop setup. (Although I was able to get your example to work.) Try this and see if it works for you. The {filecontents} environment is just a way of including a specific bib file within the source document. You wouldn't need it for your actual document.

\documentclass[endnotes]{apa6e}
\usepackage[american]{babel}
\usepackage{csquotes} 
\usepackage[style=apa]{biblatex} 
\DeclareLanguageMapping{american}{american-apa}
\usepackage[T1]{fontenc}
\title{A title}
\author{An Author}
\shorttitle{A title}
\authornote{}
\abstract{An abstract}

\begin{filecontents}{apa-test-bib.bib}
@book{Saussure1995,
    Author = {Ferdinand de Saussure},
    Origyear = {1916},
    Publisher = {Payot},
    Title = {Cours de Linguistique G{\'e}n{\'e}rale},
    Year = {1995}}

@book{Labov1972,
    Address = {Philadelphia},
    Author = {William Labov},
    Publisher = {University of Pennsylvania Press},
    Title = {Sociolinguistic Patterns},
    Year = {1972}}

\end{filecontents}
\addbibresource{apa-test-bib.bib}

\begin{document}
\maketitle

This is some text. \cite{Saussure1995,Labov1972}
\printbibliography
\end{document}
  • 1
    Starting from biblatex v3.8/biblatex-apa v7.5 there should be no need for manual \DeclareLanguageMappings any more. biblatex-apa now automatically sets the mappings for all languages with \DeclareLanguageMappingSuffix{-apa}. – moewe Dec 28 '17 at 21:49
0

If using polyglossia (needed if using luaLaTeX/XeTeX for the Times New Roman TTF fonts), the line becomes:

\DeclareLanguageMapping{english}{english-apa}

(Source: http://mirrors.ucr.ac.cr/CTAN/macros/latex/contrib/biblatex-contrib/biblatex-apa/biblatex-apa.pdf, pg 5)

I am Using LyX with biblatex, and my preamble is:

\usepackage{polyglossia}
\setdefaultlanguage{english}
\usepackage[style=apa, natbib=true, sortcites=true, sorting=ynt, backend=biber]{biblatex}
\DeclareLanguageMapping{english}{english-apa}
\addbibresource{References.bib}

If using LyX - make sure to remove the default loaded Natbibapa from the Modules under Document -> Settings. I have created a Biblatex-citation-styles module as given at: https://wiki.lyx.org/BibTeX/Biblatex

#\DeclareLyXModule{Biblatex-citation-styles}
#DescriptionBegin
#A prerequisite for using the biblatex package. This module simply
#enables the author/year citation styles without actually loading natbib.
#Biblatex itself needs to be loaded manually. Cf.
#http://wiki.lyx.org/BibTeX/Biblatex
#DescriptionEnd

Format 11

# this is biblatex actually
Provides natbib         1

The is saved as biblatex.module under ~/.lyx/layouts

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.