2

It seems like that the options footlines and footheight are ignored if areaset is used. Consider the following MWE

\documentclass[footheight=30pt]{scrlttr2}

\usepackage{scrlayer-scrpage}

\pagestyle{scrheadings}
\clearscrheadings
\cfoot{foo \\ bar}

\areaset{17cm}{25cm}

\begin{document}
Hello
\end{document}

Although footheight=30pt is set I get the following warning if compiled:

Package scrlayer-scrpage Warning: \footheight to low.
(scrlayer-scrpage)                At least 28.99998pt needed,
(scrlayer-scrpage)                but only 18.125pt found.
(scrlayer-scrpage)                I'll enlarge \footheight, for further
(scrlayer-scrpage)                processing, but you should do this yourself,
(scrlayer-scrpage)                e.g., setting typearea's option
(scrlayer-scrpage)                `footheight=28.99998pt'.
(scrlayer-scrpage)                I'll also increase \footskip on input line 13

The problem still persists if footlines=2.1 is used. Any ideas what is going wrong here?

2

By default \areaset ignores options headheight, headlines, footheight and footlines. This is documented in the KOMA-Script manual scrguien.pdf (English) and scrguide.pdf (German). And in Part II of the KOMA-Script manual you can find option areasetadvanced, that changes the behaviour. Nevertheless there are still some difference in details of the margin calculation used by \typearea and \areaset. Have a look at the manual for more information.

\documentclass[footheight=30pt,areasetadvanced]{scrlttr2}

\usepackage{scrlayer-scrpage}

\pagestyle{scrheadings}
\clearscrheadings
\cfoot{foo \\ bar}

\areaset{17cm}{25cm}

\begin{document}
Hello
\end{document}
  • Yes that fixed it. Thanks for letting me know! – Max Maier Apr 9 '17 at 11:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.