I’m trying to switch from XeLaTeX to LuaLaTeX but unfortunately the latter doesn’t seem to find fonts that are organised with FontExplorer X, while XeTeX hasn’t any problems. The following example works fine with XeLaTeX but with LuaLaTeX I only get the font-not-found error message:

% !TeX program = lualatex
% !-TeX program = xelatex

\setmainfont{Minion Pro}


When I change the font to Arial (which is in anther font folder, see below) LuaLaTeX works.

After reading $OSFONTDIR on OSX I tried to add the FontExplorer folder to $ODFONTDIR but without success:

Tobis-Mac:~ Tobi$ export OSFONTDIR="/Users/Tobi/FontExplorer X/Font Library/":$OSFONTDIR
Tobis-Mac:~ Tobi$ echo $OSFONTDIR
/Users/Tobi/FontExplorer X/Font Library/:
Tobis-Mac:~ Tobi$ luaotfload-tool --update
Tobis-Mac:~ Tobi$ luaotfload-tool --find="Arial"
luaotfload | resolve : Font "Arial" found!
luaotfload | resolve : Resolved file name "/Library/Fonts/Arial.ttf"
Tobis-Mac:~ Tobi$ luaotfload-tool --find="Minion Pro"
luaotfload | db : Reload initiated (formats: otf,ttf,ttc); reason: "Font Minion Pro not found.".
luaotfload | resolve : sequence of 3 lookups yielded nothing appropriate.
luaotfload | resolve : Cannot find "Minion Pro" in index.
luaotfload | resolve : Hint: use the --fuzzy option to display suggestions.
Tobis-Mac:~ Tobi$

See edit history of this post for the version with escaped space instead of double quotes.

I know that XeTeX and LuaTeX handle font loading differently but how can I make LuaTeX work with fonts saved in /Users/Tobi/FontExplorer X/Font Library/?

I’m working with MacTeX alias TeX Live 2016 (up to date) and FontExplorer X Pro 5.5.1 on macOS Sierra 10.12.4.

Tobis-Mac:~ Tobi$ xelatex -v
XeTeX 3.14159265-2.6-0.99996 (TeX Live 2016) 
Tobis-Mac:~ Tobi$ lualatex -v
This is LuaTeX, Version 0.95.0 (TeX Live 2016)

Information of the fonts

enter image description here

enter image description here

  • I don't have a mac, but your handling of the space in the path looks odd. Why don't you quote it? "/Users/Tobi/FontExplorer X/Font Library/" Apr 9, 2017 at 10:14
  • The space is escaped (that’s the way macOS does it if I drag a folder in the terminal app). However the result with double quotes is exactly the same … (see edit)
    – Tobi
    Apr 9, 2017 at 10:59
  • And what happens if you use the full path (that means add the M/Minion Pro/)? Apr 9, 2017 at 11:03
  • 1
    That $OSFONTDIR isn't searched recursively was an issue in the past, cf. tex.stackexchange.com/a/275072/29873
    – DG'
    Apr 9, 2017 at 11:07
  • 1
    @Tobi Setting $OSFONTDIR to $HOME/FontExplorer X/Font Library// (two slashes at the end) seems to work. At least luaotfload-tool --find="Minion Pro" finds the font now
    – DG'
    Apr 9, 2017 at 11:12

1 Answer 1


Kpathsea searches a given path recursively if it ends with two slashes (//). Accordingly

export OSFONTDIR="$HOME/FontExplorer X/Font Library//"
luaotfload-tool --update

should work. And indeed

luaotfload-tool --find="Minion Pro"


luaotfload | resolve : Font "Minion Pro" found! 
luaotfload | resolve : Resolved file name "/Users/<username>/FontExplorer X/Font Library/M/Minion Pro/MinionPro-Regular.otf"

compiling your MWE works also

enter image description here

and pdffontsreturns

name                                 type              encoding         emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
YSSVEJ+MinionPro-Regular             CID Type 0C       Identity-H       yes yes yes      4  0
  • Hi, sorry for the late reply. I already tried your suggestion after you commented but forgot to answer O:-) However it works finde now. Thanks!
    – Tobi
    Apr 10, 2017 at 13:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .