0

I'm running Debian Jessie and my LaTeX was running smoothly until I replaced one of the packages in /usr/local/share/texmf/tex/latex/... and ran texhash. It seemed to succeed, but...

Now, LaTeX cannot find ANY of the packages in that folder (or anywhere else in /usr/local/share/texmf/tex/latex/, whether I run latex or pdflatex).

Has this happened to anyone else before? Does anyone know what the problem may be?

Thanks in advance.

Note: /usr/local/share/texmf/ls-R contains the packages which LaTeX cannot find, and when I run texhash, the first line it shows is:

texhash: Updating /usr/local/share/texmf/ls-R...
  • Take a look at /usr/local/share/texmf/ls-R file. Is it readable? Does it have the list of files? – Boris Apr 11 '17 at 14:07
0

A wild guess: try as a root

chmod -R a+r /usr/local/share/texmf/
  • Thanks! I don't know what caused the permissions on that folder to change, but it looks like that was it. – Gabriela Apr 12 '17 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.