0

I would likt to use NotoSans as font for chapter and section titles; the document text should be in a different font. When I load the noto package and try to change the font of titles, a corupted pdf document is produced - I compile with PDFLaTeX with no errors, I just cannot open the PDF. However, while compiling, I can see that the notoSans-tlf-t1 basis could not be created. I am not sure what that means and how can I fix it.

Here is the code I use:

\documentclass[a4paper, 12pt, english]{report}
\usepackage[sf]{noto}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[american]{babel}
\usepackage{titlesec}
\titleformat{\chapter}[block]
{\filcenter\normalfont\sffamily\Large\bfseries}%
{}{1em}{}

\begin{document}
\chapter{Test}
\end{document}
4
  • If your document uses UTF-8, then the only option to inputenc should be utf8. The command \sf has been deprecated for more than 20 years: use \sffamily. Anyway, I suspect a corrupt TeX installation: what TeX distribution are you using?
    – egreg
    Apr 12 '17 at 8:41
  • When you get an error you should show the complete and exact error message. You should also mention your texsystem. Don't load inputenc with two options, your document is either utf8 or latin9, not both. Apr 12 '17 at 8:41
  • Thank you both! I was not able to copy the error since it was shown during compilation only - it disappeared afterwards (it was not in the log). However, the reason seems to be that the NotoSans-tlf-t1--base source file could not be found. As Admin i do not encounter the problem, when logged in as user, I still do (although I updated the file name data base as both admin and user). Thanks for the comment on \sf and UTF-8 - I changed those!
    – latexQ
    Apr 12 '17 at 9:26
  • Then run on a command line updmap (assuming that you are using miktex). One should certainly not use an admin account because of such a problem. Apr 12 '17 at 10:02
0

I am having no errors or warnings, and no problem with the pdf file, with the following slight modifications:

\documentclass[a4paper, 12pt]{report}
\usepackage[sf]{noto}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[american]{babel}
\usepackage{titlesec}
\titleformat{\chapter}[block]
{\filcenter\normalfont\sffamily\Large\bfseries}%
{}{1em}{}

\begin{document}
\chapter{Test}
\end{document}
1
  • Thank you! I just figured out that the problem was due to being logged in as admin or user - now it works. Thanks!
    – latexQ
    Apr 12 '17 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.