7

I just updated my MiKTeX package and in doing so, I started getting two strange errors repeated over and over. I'm running Windows 10.
The errors are as follows:

Package xkeyval Error: family_i' undefined in familiesblx@opt@namepart'. \newpage
Package xkeyval Error: given_i' undefined in familiesblx@opt@namepart'. \newpage

The errors comes, stacked, on the line after \printbibliography.
After the update, I've been, unsuccessfully, running Biber version 2.7 and biblatex version 3.7, and neither is included in biber compatibility matrix.

Is anyone else having this problem, and if so, how did you solve it?

I don't have a MWE because the error started after I updated my packages, and even other documents that were working before the update gives the same error.
I updated MiKTeX as both user and admin, and I cleared the C:\...\AppData\Roaming\MiKTeX\ folder. MiKTeX recreates the repository successfully but the error remains.

PS: I haven't been able to find this error on stackexchange yet, but if it is a duplicate please close it and point me in the right direction.

Edit: I call biblatex with the following line:

\usepackage[maxcitenames=2, citestyle=authoryear,%
bibstyle = authoryear, maxbibnames=2,%
backend=biber, hyperref=true]{biblatex} 
  • Try to remove all intermediate files like .aux, .bbl, .bcf and may be more. They may contain stuff which does not work with the new version (happened to me more than once). – Thomas F. Sturm Apr 12 '17 at 9:45
  • If you made a large version jump it is quite possible to you are now affected by the changes in the name part definitions last year. But without a minimal example it is difficult to say. In any case as a first try delete all auxiliary files. – Ulrike Fischer Apr 12 '17 at 9:46
  • @ThomasF.Sturm Yes, it worked. Haha. Thank you so much, so simple, yet I wouldn't have thought of it. – Baraliuh Apr 12 '17 at 9:49
  • @UlrikeFischer Yes, thank you for the input, it did indeed work. I would have provided a MWE if it was demanded. But I didn't know if it was necessary or not, I try to keep my MiKTeX up to date :) – Baraliuh Apr 12 '17 at 9:51
  • 1
    @ThomasF.Sturm could write an answer and I will accept that answer and this thread can be closed. Again, thank you for your help – Baraliuh Apr 12 '17 at 9:52
9

When biber or biblatex is updated, auxiliary and/or intermediate files from former compilations may contain invalid data for the new version.

Deleting such files with suffixes .aux, .bbl, .bcf, .run.xml, ... removes this data and the source file can be compiled again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.