1

I am new to TeX Stackexchange and I do have a question. I hope that you can help me.

I am working with a beamer presentation and I prepare my TikZ pictures in a separate document (article class). I do get an integral sign via \iint like the following:

enter image description here

In my preparation document I get this by using the same code:

enter image description here

As you can see, the integral sign is not upright. The preparation document and the presentation use the same packages. Does anyone know how to fix this?


EDIT:

Here is a MWE:

\documentclass[ngerman, trans]{beamer}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{amsmath,tikz,pgf,amssymb,graphicx,commath,pifont,fancybox,setspace,multicol,mathtools,pgfplots}
\usepackage{sfmath}
\usepackage{esint}
\usepackage{verbatim}
\usepackage[absolute, overlay]{textpos}
\usepackage{fancyvrb,xcolor,tabularx,fontawesome,empheq,epstopdf,circuitikz,mdframed}
\usetikzlibrary{arrows,calc}

\begin{document}
\begin{frame}
$$\iint_A \vec{v}\circ\dif\vec{A}$$
\end{frame}
\end{document}

Thanks to the answer of Henri Menke, he brought me to the idea to do something with the wasysym package. By using the wasysym package in this configuration, I got something like 'option clash'. By deleting wasysym, it works with no upright integral signs.

  • 2
    Welcome to TeX.SX! Please help us help you and add a minimal working example (MWE) that illustrates your problem. Reproducing the problem and finding out what the issue is will be much easier when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – Dai Bowen Apr 13 '17 at 20:44
  • 1
    Which font do you use for your article document? Did you alreay try to use the same font for your beamer document? Maybe \usefonttheme{professionalfonts} is necessary, but without having a MWE this is hard to know. – user36296 Apr 13 '17 at 20:53
  • 2
    Main issue is of course that beamer uses a different set of base fonts and thus text text and math look different. Any particular you don't just include the tikz directly into the beamer doc instead of precompiling them? – daleif Apr 13 '17 at 20:53
3

Use the wasysym package (as you do in your document).

\documentclass{beamer}
\usepackage{wasysym}
\begin{document}

\begin{frame}
  \[ \iint \vec{v} \circ \mathsf{d}\vec{A} \]
\end{frame}

\end{document}

enter image description here

  • Thanks for your answers! The hint with the 'wasysym' package did work well. – Christoph Apr 14 '17 at 5:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.