5

When exporting to PDF, my EPS figures (graphs created in EViews) have white vertical lines running through them (see below) - although these disappear when I zoom in and in print.

Could someone help me solve this problem?

I am currently using Lyx and Adobe/Sumatra PDF viewers.

Thanks

Link to EPS file: https://www.dropbox.com/s/0yliz64rrgyqhg0/alt_var.pdf?dl=0

enter image description here

closed as off-topic by Torbjørn T., TeXnician, Zarko, user31729, egreg Jun 4 '17 at 11:15

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center." – Torbjørn T., TeXnician, Zarko, Community, egreg
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 8
    (1) welcome, (2) it would be useful for us to see such eps files as we might not be familiar with EViews (I've never heard of it). (3) it is most likely due to rounding errors when displaying the image on screen as you have already noticed they disappear when you zoom in – daleif Apr 14 '17 at 10:20
  • 3
    @ts_highbury I suppose that the white lines are due to the rasterization effect by your PDF viewer, and IMO I think that it will not be present when you take a printout of the document. Moreover, did you try printing your document with this figure on it? – Raaja Apr 14 '17 at 11:43
  • 1
    @ts_highbury Then it's the problem that usually happens (for myself as well from Matlab 2014b) due to the PDF trying to display the figure by using its internal rasterization, to be honest, I don't know how to solve this. As far as I don't affect your printed documents, then I suppose the job is done :) – Raaja Apr 14 '17 at 12:08
  • 2
    @ts_highbury I only see the artifacts in your pdf when turning on the "smooth line art" option in acrobat reader options. Makes me think this is an aliasing problem. I don't see the lines in evince/Linux, even though that used be a huge issue for me a few years back. The lines are there in Inkscape. Can you use any other kind of shading? Darker, patterned? – PhilipPirrip Apr 14 '17 at 13:40
  • 4
    @ts_highbury I've just checked the file in Inkscape. Looks like your program saves those problematic trapezoids as two: the top one is filled but has no stroke paint, then the same one underneath has stroke color set, and no filling. Shouldn't be too hard to fix in Inkscape (select the elements with F2 tool, change colors appropriately). – PhilipPirrip Apr 14 '17 at 13:57

Browse other questions tagged or ask your own question.