5

When I have minus signs in superscripts, they disappear when printing out the pdf that pdflatex produces, but only when using the scrartcl documentclass, not article. For example,

\documentclass{article}

\begin{document}
\(x^{-1}\)
\end{document}

and

\documentclass{scrartcl}

\begin{document}
\(x^{-1}\)
\end{document}

both produce a pdf which looks like this:

x with superscript minus one

However, when I print out the pdf generated from the first one, I get

printed x with superscript -1

whereas printing out the pdf generated from the second one gives

printed x with superscript 1

How can I fix this?

Edit

You are all correct in suggesting that this is being caused by the different default font sizes in article and scrartcl. This reproduces the problem:

\documentclass[11pt]{article}

\begin{document}
\(x^{-1}\)
\end{document}

While this does not:

\documentclass[10pt]{scrartcl}

\begin{document}
\(x^{-1}\)
\end{document}

This is the log file for the 11pt article case:

This is pdfTeX, Version 3.14159265-2.6-1.40.17 (TeX Live 2016/Arch Linux) (preloaded format=pdflatex 2017.3.15)  16 APR 2017 10:29
entering extended mode
 restricted \write18 enabled.
 file:line:error style messages enabled.
 %&-line parsing enabled.
**\input mcve.ltx
(./mcve.ltx (/usr/share/texmf-dist/tex/latex/base/article.cls
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
(/usr/share/texmf-dist/tex/latex/base/size11.clo
File: size11.clo 2014/09/29 v1.4h Standard LaTeX file (size option)
)
\c@part=\count79
\c@section=\count80
\c@subsection=\count81
\c@subsubsection=\count82
\c@paragraph=\count83
\c@subparagraph=\count84
\c@figure=\count85
\c@table=\count86
\abovecaptionskip=\skip41
\belowcaptionskip=\skip42
\bibindent=\dimen102
) (./mcve.aux)
\openout1 = `mcve.aux'.

LaTeX Font Info:    Checking defaults for OML/cmm/m/it on input line 3.
LaTeX Font Info:    ... okay on input line 3.
LaTeX Font Info:    Checking defaults for T1/cmr/m/n on input line 3.
LaTeX Font Info:    ... okay on input line 3.
LaTeX Font Info:    Checking defaults for OT1/cmr/m/n on input line 3.
LaTeX Font Info:    ... okay on input line 3.
LaTeX Font Info:    Checking defaults for OMS/cmsy/m/n on input line 3.
LaTeX Font Info:    ... okay on input line 3.
LaTeX Font Info:    Checking defaults for OMX/cmex/m/n on input line 3.
LaTeX Font Info:    ... okay on input line 3.
LaTeX Font Info:    Checking defaults for U/cmr/m/n on input line 3.
LaTeX Font Info:    ... okay on input line 3.
LaTeX Font Info:    External font `cmex10' loaded for size
(Font)              <10.95> on input line 4.
LaTeX Font Info:    External font `cmex10' loaded for size
(Font)              <8> on input line 4.
LaTeX Font Info:    External font `cmex10' loaded for size
(Font)              <6> on input line 4.
 [1

{/var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map}] (./mcve.aux) ) 
Here is how much of TeX's memory you used:
 220 strings out of 493013
 2322 string characters out of 6139317
 53632 words of memory out of 5000000
 3844 multiletter control sequences out of 15000+600000
 6379 words of font info for 23 fonts, out of 8000000 for 9000
 1141 hyphenation exceptions out of 8191
 21i,4n,19p,117b,107s stack positions out of 5000i,500n,10000p,200000b,80000s
 </home/will
/.texlive/texmf-var/fonts/pk/ljfour/public/cm/cmr10.657pk> </usr/share/texmf-di
st/fonts/pk/ljfour/public/cm/dpi600/cmr8.pk> </home/will/.texlive/texmf-var/fon
ts/pk/ljfour/public/cm/cmsy8.600pk> </home/will/.texlive/texmf-var/fonts/pk/ljf
our/public/cm/cmmi10.657pk>
Output written on mcve.pdf (1 page, 2342 bytes).
PDF statistics:
 28 PDF objects out of 1000 (max. 8388607)
 20 compressed objects within 1 object stream
 0 named destinations out of 1000 (max. 500000)
 1 words of extra memory for PDF output out of 10000 (max. 10000000)

As for my system and the printer itself, I'm running Arch Linux and printing via CUPS. The printer is an HP OfficeJet Pro 8600. CUPS lists the driver as HP Officejet Pro 8600 hpijs, 3.16.11 (color, 2-sided printing), which I got by installing the hplip package. There do not appear to be any font rendering options in the print dialog or in CUPS.

  • Show also the log file so that we can see the texsystem, the version and the fonts used. – Ulrike Fischer Apr 16 '17 at 8:13
  • can't replicate here on a linux system using tex live 2016. – barbara beeton Apr 16 '17 at 14:53
  • Uh! Your TeX system is using bitmap fonts! Please, do a full install of TeX Live. – egreg Apr 16 '17 at 14:54
  • @egreg Aha! I had installed the package texlive-core on my system, but apparently that does not include all the fonts that I need. I replaced it with texlive-most and now the problem is resolved. If you make your comment into an answer I'll accept it. – Will Kunkel Apr 16 '17 at 15:04
2

This part of your log file is the most significant:

 </home/will
/.texlive/texmf-var/fonts/pk/ljfour/public/cm/cmr10.657pk> </usr/share/texmf-di
st/fonts/pk/ljfour/public/cm/dpi600/cmr8.pk> </home/will/.texlive/texmf-var/fon
ts/pk/ljfour/public/cm/cmsy8.600pk> </home/will/.texlive/texmf-var/fonts/pk/ljf
our/public/cm/cmmi10.657pk>

It basically means you are using bitmap fonts for your PDF output. Depending on the PDF viewer this can cause apparent disparition of symbols that would show up at different magnifications.

Install a full TeX Live, so Type1 (outline) fonts will be used, which have hints for display at various magnifications/resolutions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.