1

Reproduce:

  • Get Forward-search working
  • Have TeXstudio opened
  • Have the compiled PDF file opened with SumatraPDF

  • Open a second different pdf with SumatraPDF

  • Click on it so that this document is in focus
  • Go back to TeXstudio
  • Do a forward search

Result:

New (third) pdf is opened and searched

Expected:

Go to already opened file and search there

Some info which I think may be relevant:

  • It works if the correct window was in focus before changing to TeXstudio and searching
  • Command used for forward search: dde:///"C:/Program Files/SumatraPDF/SumatraPDF.exe":SUMATRA/control/[ForwardSearch("?am.pdf","?c:am.tex",@,0,0,1)]
  • Command to open external PDF viewer: "C:/Program Files/SumatraPDF/SumatraPDF.exe" -reuse-instance %.pdf
  • Tabs are off in SumatraPDF
  • Windows 7

I also tried the settings proposed here and got the same result: TexStudio, MiKTeX and Sumatra; Compilation Issue

Question:

Is the issue I am experiencing a bug or did I do something wrong? If this is a bug, do I report it to TexStudio or to SumatraPDF?

  • @DiaaAbidou Sorry, but have you read my the description completely? Especially the part where I referenced another post that basically had the same things set up as your post? Did you even understand that I do not need help to set up forward search? – doc Apr 17 '17 at 23:54
  • You could have overlooked my comment or said thanks it is irrelevant instead of this interrogation. – Diaa Apr 18 '17 at 3:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.