0

I am using the scrartcl document class to write my CV, but the page number on the second page has moved from the bottom of the page to a rather unsightly position at the top of the second page.

How can I move the page number back to the bottom of the page or remove it completely?

My document layout is below:

\documentclass{scrartcl}    % classe article di KOMA
\usepackage[right=2cm]{geometry}

\reversemarginpar
\newcommand{\MarginDate}[1]{\marginpar{\raggedleft\itshape\small#1}}

\usepackage[LabelsAligned]{currvita}    % un buon pacchetto per CV
\usepackage[nochapters]{classicthesis} % stile ClassicThesis
\usepackage{url}    % per gli indirizzi Internet
\renewcommand{\cvheadingfont}{\LARGE\color{Blue}}
\renewcommand{\cvlistheadingfont}{\large}
\renewcommand{\cvlabelfont}{\qquad}
%Setup hyperref package, \& colours for links, text \& headings
\usepackage{hyperref}       
\hypersetup{    colorlinks,breaklinks,
        urlcolor=Maroon, 
        linkcolor=Maroon}
\usepackage{eurosym}
\usepackage{lipsum} 
\newlength{\datebox}\settowidth{\datebox}{Summer 20070}

\newcommand{\NewWorkExperience}[3]

{\noindent\hangindent=0.7em\hangafter=0 \parbox{\datebox}

{\textit{#1}}\hspace{0em} #2 #3%
\vspace{0.1em}}

\newcommand{\Description}[1]

    {\hangindent=0em\hangafter=0\noindent\raggedright\footnotesize{#1}\par\normalsize}

\newcommand{\Sep}{\vspace{0.6em}}
\begin{document}
\thispagestyle{empty}
\begin{cv}{\spacedallcaps{Aveshen Pillay}}
\vspace{1.5em}

\noindent\spacedlowsmallcaps{Personal Data}

\lipsum[2-4]

\noindent\spacedlowsmallcaps{Professional Experience}

\lipsum[2-4]

\enlargethispage{\baselineskip}
\end{cv}
\end{document}
  • 1
    Welcome to TeX.SX! Unfortunately the example in your question does not work. At least \begin{document} is missing. And even with an added \begin{document} it throws several error messages. Please edit your question and improve the example to make it a MWE. Without we cannot reproduce your problem to give you a good answer. – Schweinebacke Apr 18 '17 at 17:30
  • The errors are caused by the misused \parbox{\datebox}... lines. – Skillmon Apr 18 '17 at 17:32
  • Also your MWE doesn't recreate your problem. – Skillmon Apr 18 '17 at 17:35
  • @Skillmon - thank you for your help. I will edit the code for the MWE shortly. I just compiled it in TexStudio and it reproduced the error. – Aveshen Pillay Apr 18 '17 at 17:44
  • 1
    The page style is part of package classicthesis, which uses code not recommended for class scrartcl. If you do not want/need it, remove it. You can change the margins of your document either using KOMA-Script option DIV (see scrguien.pdf) or package geometry. You can have spaced upper case or small caps using package microtype. You can have colors using package xcolor. – Schweinebacke Apr 18 '17 at 17:51
2

If you do not want a page number and not other page header or footer, simply replace

\thispagestyle{empty}

by

\pagestyle{empty}

\thispagestyle changes the page style of the current page only. \pagestyle changes the page style of all pages from the current one.

Nevertheless, I would recommend not to use classicthesis. Removing all not needed code and errors, you could use:

\documentclass{scrartcl}    % classe article di KOMA
\usepackage[right=2cm]{geometry}
\reversemarginpar
\newcommand{\MarginDate}[1]{\marginpar{\raggedleft\itshape\small#1}}
\usepackage[LabelsAligned]{currvita}    % un buon pacchetto per CV
\usepackage[svgnames]{xcolor}
\usepackage{microtype}
\renewcommand{\cvheadingfont}{\LARGE\color{Blue}}
\renewcommand{\cvlistheadingfont}{\large}
\renewcommand{\cvlabelfont}{\qquad}
%Setup hyperref package, \& colours for links, text \& headings
\usepackage{hyperref}       
\hypersetup{    colorlinks,breaklinks,
            urlcolor=Maroon, 
            linkcolor=Maroon}
\usepackage{eurosym}
\usepackage{blindtext}
\begin{document}
\thispagestyle{empty}% No page number on the first page
\begin{cv}{\textsc{\textls{Name Surname}}}
\vspace{1.5em}
\Blindtext[10]
\end{cv}
\end{document}

This would result in:

with \thispagestyle{empty}

or without \thispagestyle{empty}:

without \thispagestyle{empty}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.