I've seen this question on a closed post on this forum, but the answer given there does not solve my problem. I'm an unexperienced LaTeX user, using TeXnicCenter, and MikTeX 2.9 on 64-bit Windows 7. Whenever I try to compile a .tex file (also ones that used to work perfectly on my 32-bit Vista pc), I get the error

pdflatex.exe: the memory dump file could not be found.

I've already tried suggestions from other forums, like making sure there are no spaces in the path to MikTeX (i.e. not putting it in Program Files), but they don't solve the problem. Also one suggestion said to go to start-> all programs -> MikTeX 2.9 -> maintenance(admin) -> settings(admin) -> formats, then click the pdflatex.exe file and build it. Either I misunderstood the directions, or something is wrong in my MikTeX, because the formats list is empty. Also when I clicked the formats tab, it gave this error:

no formats.ini exists.

But when searching manually I did find this file in MiKTeX2.9/miktex/config.. Can someone please help me with this, thank you :)

  • Are you in your user account? What happens if you open the non-admin version of miktex settings? – Ulrike Fischer Nov 29 '11 at 22:30
  • If you've "already tried suggestions from other forums", then you would need to post more information. How about making a minimal working example (MWE) and posting the entire .log file as part of your post. Use, say, \documentclass{article}\begin{document}Hello world.\end{document}. – Werner Nov 29 '11 at 23:44
  • The same thing happens whether I use the admin or non-admin version of miktex settings. – sara Nov 30 '11 at 11:30
  • Where can I find the .log file, or how can I generate it? – sara Nov 30 '11 at 11:32
  • Well this doesn't sound good. If miktex can't find formats.ini it can't generate the formats and then pdflatex can't work. It looks as if your installation is broken. In general I'm not a friend of reinstalling miktex but in this case I think you should try it - it will probably cost less time than trying to debug the installation. If you reinstall consider to install miktex in your user account "only for you". See my answer here: tex.stackexchange.com/questions/29616/…. – Ulrike Fischer Nov 30 '11 at 14:02

A community wiki answer, to not let the question open:

The problem was solved by the OP by first reinstalling MiKTeX, which did not help yet, and reinstalling TeXnicCenter.

| improve this answer | |

Sometimes, installing over an older version inherits some settings not really wanted. In this case, make sure you do not have another (older) formats.ini lying somewhere in the MiKTeX tree. If so, keep the ...\miktex\config\formats.ini. Then, with the MiKTeX Maintenance (admin) tool, rebuild the file database and the formats.

| improve this answer | |

I had the same problem. Reinstalling MiKTeX with a thorough clean-up did not work for me.

Running TexWorks as Administrator worked for me. It needed to install packages.

| improve this answer | |
  • OP gets the error "error: pdflatex.exe: the memory dump file could not be found" and is looking for a solution. My solution is to run the TexWorks with administrator privileges. It answers the question and solves the problem. What other threads of problem-solving OP has tried is irrelevant - he wants the error gone. – Mikal Madsen Dec 11 '14 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.