8

While using the 2017 release of Adobe Acrobat DC, I get the error

error WinEdt Adobe Acrobat DC 2017

every time I run PDFLatex with my PDF open. When I use PDF Search, I get the same error.

Does anybody know what do I have to change in the .edt files to make it work?

  • 2
    Update your winedt. Alex said he has changed the macros. Alternatively you would need to change adobe.edt to set the service to acroviewA17 (or acroviewR17). – Ulrike Fischer Apr 21 '17 at 21:08
  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – Martin Schröder Apr 22 '17 at 12:52
10

Support for Adobe Acrobat DC 2017 has been added only in WinEdt 10.2 Build 20170413.

The name of the DDE service is, in the case of Acrobat DC Pro 2017, AcroviewA17, while in the case of Adobe Reader DC 2017, AcroviewR17.

You have to insert this value in the Options menu -> Execution Modes dialog -> PDF Viewer tab -> Adobe DDE Service Blues field and the then press OK, as in the image below.

enter image description here

Notice that it might not work if you have a local copy of Adobe.edt in the path C:\Users\<user>\AppData\Roaming\WinEdt Team\WinEdt 10\Config. In this case, simply delete that file and restart WinEdt.


If you can't upgrade to the latest version of WinEdt, you can instead open a local copy of the file Adobe.edt from the Options menu -> Options Interface dialog -> Advanced Configuration -> PDF Macros -> Adobe Blues.

enter image description here

In this file, replace the line at the very end of it

// Assign(!"Acro-DDE_Service",!"AcroviewR11");

with the following

Assign(!"Acro-DDE_Service",!"AcroviewA17");

then save the file and restart WinEdt.


Addendum: Name of the DDE service for different versions of Adobe DC

  • Adobe Reader DC 2015: AcroviewR15
  • Acrobat DC Pro 2015: AcroviewA15
  • Adobe Reader DC 2017: AcroviewR17
  • Acrobat DC Pro 2017: AcroviewA17
  • Adobe Reader DC 2018: AcroviewR18
  • Acrobat DC Pro 2018: AcroviewA18

Unless Adobe changes its naming convention, for future versions it suffices to change the last two digits according to the year version.

  • Thank you very much! installing WinEdt 10 solves the problem. Thank you! Francisco – Paco Vazquez-Grande Apr 24 '17 at 13:50
  • Let me bring in the new year by saying that installing WinEdt 10, MikTex 2.9, and and the latest version of Acrobat just now required me to change the DDE name to AcroviewA19 in order to get everything to work properly. ;-) – JohnD Jan 10 at 14:08
  • Using WinEdt 10 and MikTex, I just had to change the DDE name to AcroviewR19 and then I had to restart my computer to get it working, – Peter Flom Mar 26 at 10:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.