1

[update #3 --- problem is with updmap?]

Installation Procedure

I installed comicsans via comicsans.tds.zip. a replay of my installation process is:

# sudo bash
# wget http://mirrors.ctan.org/install/fonts/comicsans.tds.zip
# wget http://www.fontsupply.com/fonts/COMICBD.TTF  # doesn't work, but you get the idea
# wget http://www.fontsupply.com/fonts/COMIC.TTF  # same thing
# cd /usr/local/texlive/texmf-local
# unzip ~/comicsans.tds.zip
# mkdir -p fonts/truetype/microsoft/comic
# cp ~/COMIC.TTF fonts/truetype/microsoft/comic/comic.ttf
# cp ~/COMICBD.TTF fonts/truetype/microsoft/comic/comicbd.ttf
# mktexlsr
# ## WRONG updmap-sys --enable Map=/usr/local/texlive/texmf-local/fonts/map/dvips/comicsans/comicsans.map 
   ## be careful: the word "Map" is case sensitive.
   ## instead, use updmap-sys --enable Map=comicsans.map # see below
# cd ~ ; texhash ; mktexlsr
# ls -l `kpsewhich comic.ttf`
  -rw-r--r-- 1 root 126364 Apr 22 15:06 /usr/local/texlive/texmf-local/fonts/truetype/microsoft/comic/comic.ttf

I misunderstood the original purpose of comicsans.sty . At this point, the comic sans fonts are available for (sparing) use, e.g., as headline fonts. You should only usepage comicsans.sty if you want to redefine the document default fonts to use comicsans.

Running Attempt

I read the installation documents on how to select comicsans, and it works:

\documentclass[12pt]{article}
\usepackage{comicsans}
\begin{document}
\newcommand*{\comicfont}{\fontfamily{comic}\selectfont}
\comicfont  %% \huge
Thanks, Scott, for making this.
\end{document}

On one computer it worked, but not on another. On both, uncomment the \huge (or use a different font size), and it fails:

kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 2+293/600 --dpi 1493 rcomic8r
mktexpk: don't know how to create bitmap font for rcomic8r.
mktexpk: perhaps rcomic8r is missing from the map file.
kpathsea: Appending font creation commands to missfont.log.

The point (pun!) of the comic font for me is to make headlines, so I need these different size versions (a bigger font).

updmap is wrong

Here is something I now learned:

# updmap
...
updmap [ERROR]: The following map file(s) couldn't be found:
updmap [ERROR]:     /usr/local/texlive/texmf-local/fonts/map/dvips/comicsans/comicsans.map (in /usr/local/texlive/2016/texmf-config/web2c/updmap.cfg)
updmap [ERROR]: Did you run mktexlsr?

huh? yes, I did run mktexlsr, both as root and as myself. I also confirmed that the file is there and readable.

# ls -l `kpsewhich comicsans.map`
  -rw-rw-r-- 1 root 1584 Dec 18  2013 /usr/local/texlive/texmf-local/fonts/map/dvips/comicsans/comicsans.map

the file that it complains about is in the right place, and the hardcoded naming dispells any doubts.


font installation remains gray magic to me, even after decades of struggles. the answer is probably obvious...but not to me.

advice appreciated.

/iaw

  • 3
    don't use \font ! just use standard latex size commands such a \Huge or \fontsize{1in}{2in}\selectfont – David Carlisle Apr 21 '17 at 21:34
  • 2
    If you are willing to use LuaLaTeX with fontspec, there is a font "Comic Relief" available from non-TeX sites under the Open Font License. Since it is a TrueType font, it is automatically scalable. – user103221 Apr 22 '17 at 0:00
  • (I thought comic.ttf also was truetype.) there is a reason to avoid lualatex: time pdflatex book = 14.4 seconds. time lualatex book = 21.9 seconds. I am hoping the latter will manage to get to 16, and then I will switch. – ivo Welch Apr 22 '17 at 18:13
  • 1
    That package does not include the actual fonts so it cannot possibly work fine unless you've installed the fonts earlier. You need to get the 2 TTF fonts, make sure they are named comic.ttf and comicbd.ttf and install them in a suitable place e.g. <TEXMFLOCAL>/fonts/truetype/microsoft/comic/. If you want to use oblique, you need to generate them. Also install the package you downloaded. Then run mktexlsr. Then run updmap-sys or edit the config and run it. Either way. Then you're done. – cfr Apr 22 '17 at 21:56
  • 1
    RobtA: Being retired, I can afford (21.9 - 14.4) = 7.5 seconds of my time...but think about it. how much of the rest of your time on earth can you afford on this ;-). – ivo Welch Apr 22 '17 at 22:10
0

The answer came from ulrike fischer in updmap: error when existing map file (fully qualified filename) is claimed to be missing? .

# updmap-sys --enable Map=/usr/local/texlive/texmf-local/fonts/map/dvips/comicsans/comicsans.map 

does not work. I need

# updmap-sys --enable Map=comicsans.map 

then it works. thanks.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.