1

I have a LaTeX document in German. The only thing I want in English are the entries of the bibliography. How do I do this?

Here is my minimal working example:

my main.tex document:

\documentclass[ngerman]{MastersDoctoralThesis}
\usepackage[backend=bibtex, style=ieee, citestyle=numeric-comp, natbib=true, sorting=none]{biblatex} 
\addbibresource{bibfile.bib} %The filename of the bibliography

\begin{document}

\chapter{SomeExampleChapter, with Kapitel, not chapter..}
example of a citation \cite{Reference1}.   Here everything is in german, e.g.  Abbildung statt figure,  Kapitel instead of chapter etc...

\printbibliography[heading=bibintoc]  

\end{document}  

and my bibfile.bib:

@article{Reference1,
    Author = {C. J. Hawthorn and K. P. Weber and R. E. Scholten},
    Journal = {Rev. Sci. Instrum.},
    Number = {12},
    Pages = {4477--4479},
    Title = {Littrow Configuration Tunable External Cavity Diode Laser with Fixed Direction Output Beam},
    Year = {2001}
}

So far the bibliography reads: C. J. Hawthorn, K.P. Weber und R.E. Scholten

I want it to be: C. J. Hawthorn, K.P. Weber and R.E. Scholten

The und should be changed to and. Apart from that, nothing should be changed.

I know similar questions have been asked, but I struggled with all the answers there.

  • Welcome to TeX SX! With the autolang=other option of biblatex, you can add the field langid to specify the language used for bibliography items on an individual basis. – Bernard Apr 21 '17 at 21:48
  • umm after adding autolang=other to the options of biblatex and adding the line langid={english}, in the bibfile.bib, I get the error: Package babel Error: Unknown language 'english'. Either you have (babel) install it or just rerun the file, respectively. I tried to fix that error with \usepackage[english,german]{babel}, but it didn't work.. – Anton Rodenhauser Apr 21 '17 at 22:23
  • @AntonRodenhauser: In this case remove either the .aux file or rerun (as suggested in the message) – user31729 Apr 21 '17 at 22:52
  • 1
    @Bernard: MastersDoctorialThesis (MDT) is said to have issues ... ask Johannes_B ;-) – user31729 Apr 21 '17 at 22:58
  • 1
    Another issue here is that both autolang=other + langid and selectlanguage will likely change other things in your references besides "and" instead of "und". It will use bibstrings for English rather than German in general. The autolang=other + langid approach allows you to use English bibstrings for English references and German bibstrings for German ones. – gusbrs Apr 21 '17 at 23:30
2

As I don't have the MastersDoctoralThesis class, I replaced it with report, und this code works fine for me:

\documentclass[english, ngerman]{report}
\usepackage{babel} 
\usepackage[backend=bibtex, style=ieee, citestyle=numeric-comp, natbib=true, sorting=none, autolang=other]{biblatex}
\usepackage[autostyle]{csquotes}
\addbibresource{bibfile.bib} %The filename of the bibliography

\begin{document}

\chapter{SomeExampleChapter, with Kapitel, not chapter..}
example of a citation \cite{Reference1}. Here everything is in german, e.g. Abbildung statt figure, Kapitel instead of chapter etc...
\nocite{*}
\printbibliography[heading=bibintoc]

\end{document} 

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.