4

I am trying to produce a bibligraphy where non-cited items in the .bib file are listed below cited references. For most purposes, the solution provided at How to split bibliography into "works cited" and "works not cited"? works fine.

However, in certain cases (apparently when I have an item crossref-ed to an enclosing item), I get the error Undefined control sequence. <argument> ...xt@context }{\abx@field@localnumber; I have tried deleting all auxiliary files as suggested in biblatex documentation to no avail.

Here's an MWE:

\documentclass{memoir}

\usepackage[defernumbers=true,annotation,backend=biber,notes]{biblatex-chicago}

\DeclareBibliographyCategory{cited}
\AtEveryCitekey{\addtocategory{cited}{\thefield{entrykey}}}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@collection{author:main,
  location = {Somewhere},
  title = {Collection Title},
  publisher = {Publisher},
  editor = {The Editor},
  date = {9999}
}

@incollection{author:item,
  author = {The Author},
  title = {Item Title},
  pages = {999},
  crossref = {author:main}
}

@book{uncited:book,
  location = {Elsewhere},
  title = {Book Title},
  publisher = {Other Publisher},
  author = {Uncited Author},
  date = {9999}
}
\end{filecontents}

\addbibresource{\jobname.bib}

\nocite{*}

\begin{document}

Some text \autocite{author:item}.

\printbibliography[category=cited]% default title for `article` class: "References"

\printbibliography[title={Further Reading},notcategory=cited]

\end{document}

I understand that defernumbers adds complexity so I'm certainly open to an alternative approach to producing the uncited listing.

3

In a non-numeric style, such as all members of the biblatex-chicago family, defernumbers makes no difference.

Your MWE works just fine if you simply drop the option defernumbers=true.

Even though we can solve the problem easily by not using defernumbers here, I believe this is a problem in biblatex and have reported the issue (#568).

  • Ah, I see. I thought that somehow we were taking advantage of some side-effect so it never occurred to me to remove that option. But I think you are right; with a different style the problem would remain. – K.G. Feuerherm Apr 23 '17 at 13:32
  • @K.G.Feuerherm defernumbers is often needed with numeric styles, but has no effect for non-numeric styles. It is quite a specific combination of things that comes together to create this bug. I was not able to reproduce it in a simpler setting. But still ... it's annoying. – moewe Apr 23 '17 at 13:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.