I want to use the package enotez because it allows you to click the endnote and link directly to the notes list. I need Roman numeral (lower case) numbers as superscripts for the endnotes. I can get this fine.

I can't, however, get the numerals in the list to b Roman numerals - they are still Arabic numerals. I've tried making a custom enotez-list as per the package instructions. This works for e.g. \textsuperscript{#1} but whatever I try I can't get a Roman numeral function to play with the #1 macro. Any thoughts? MWE below and print out of what the working, wrong version looks like.



 notes-sep = \baselineskip ,
 format = \normalfont ,
 % number = \roman{#1} % broken attempt
 number = \enmark{#1}


Hello life\endnote{This is an endnote.}



Working wrong code

  • This was working with version 0.7c of the package. It looks like a bug. – TonioElGringo Apr 24 '17 at 12:42
  • Thanks for replying: tried your suggestion and it breaks. Error at the \printendnotes command: Missing number, treated as zero. []. Do you know what would cause that @clemens? – mr_phd Apr 24 '17 at 12:55
  • @mr_phd yes, it was wrong – clemens Apr 24 '17 at 12:58
  • @clemens I happen to have a enotez.sty file with {enotez}{2014/02/04}{0.7c} that produce OP's expected result with their MWE. Using the latest version on CTAN, I get the same result as OP. Looking at the source diff, there is some difference in the treatment of the counter_format option. – TonioElGringo Apr 24 '17 at 13:01
  • @clemens On the latest CTAN version, lines 256 and 267, if I replace \arabic {endnote} with \theendnote, it produces the requested result. Which is the expected and correct result, I don't know. – TonioElGringo Apr 24 '17 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.