1

I needed to update some packages and I was recommended to update all, which I did (in process). But now I can't compile anymore, I get errors like "pdftex.def not found". Is it because the updating process is not yet finished? I'm really scared that my document is damaged now...

2017-04-24 18:23:20 +0000 Warning tlu_ipctask[94383]    TLDownload::get_file: response error: 500 read timeout

2017-04-24 18:32:44 +0000 Warning tlu_ipctask[94383]    TLDownload::get_file: response error: 500 read timeout

2017-04-24 18:51:22 +0000 Warning tlu_ipctask[94383]    TLDownload::get_file: response error: 500 read timeout

2017-04-24 19:00:49 +0000 Warning tlu_ipctask[94383]    tlmgr: action update returned an error; continuing.

2017-04-24 19:03:13 +0000 Warning tlu_ipctask[94383]    tlmgr: An error has occurred. See above messages. Exiting.

2017-04-24 19:03:15 +0000 Error tlu_ipctask[94383]  *** ERROR *** exit status of pid = 94384 was 1
  • Can you still open and edit the *.tex file with your editor? Then your document is safe (unless you delete the file). Sounds like something went wrong when you updated your TeX distribution (TeX Live I guess? How did you update it?) – clemens Apr 24 '17 at 19:14
  • The .tex file can be opened. I updated my question (Log). I don't really understand the problem. – Cathy Apr 24 '17 at 19:28
  • The error messages seem to be saying that either your internet connection was too slow or went down, or else the site you were downloading from crashed for some reason (which had nothing to do with you.) I would just try the tlmgr update again. tlmgr does some things after all the downloads have completed, and they were probably not done because of the errors - therefore your TeX installation is unusable, but your own data files should be unaffected. – alephzero Apr 24 '17 at 19:46
  • What command did you use to update your distribution? Are you using TeX Live 2016? What repository are you using? – Herb Schulz Apr 24 '17 at 20:02
  • I clicked on "Update All Packages". Yes, I am using TeX Live 2016, my repository is mirror.physik-pool.tu-berlin.de/tex-archive/systems/texlive/… It actually works again, but I have no idea what happened. Should I try the tlmgr update again or just leave it at that? – Cathy Apr 24 '17 at 20:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.