1

As I was working on my document, I found that suddenly my ForwardSearch stopped working. A MWE is very simple:

\documentclass{elsarticle}
\begin{document}
This doesn't work.
\end{document}

Note that it's not necessarily an issue with elsarticle because I already tried just using the article class, with the same result.

I have followed all the rules for setting up TeXnicCenter and SumatraPDF for ForwardSearch, as outlined here:

How to configure TeXnicCenter 2.0 with Sumatra (2013--2016 version)

I have also looked at the following: TeXnicCenter - Forward search issue [closed], which was closed as "too localized." Nevertheless, I tried the solutions there as well. The same poster put up an MWE: TeXnicCenter Crashes on BUILD and VIEW OUTPUT [closed], which was also closed as too localized.

And I've seen “Cannot Execute the Command” error with sumatraPDF in TeXnicCenter. This one is the closest to my issue, but none of the suggestions there worked either (like restarting TeXnicCeter, etc.)

My real document has a nomenclature section which uses the makeindex executable to build a nomencl *.nlo file. Thus, my build configuration is as follows:

(La)TeX Build Options

Command line arguments to pass to the compiler: -synctex=-1 -max-print-line=120 -interaction=nonstopmode "%Wm"

Viewer Options Executable path: C:\Program Files\SumatraPDF\SumatraPDF.exe -inverse-search "\"C:\Program Files\TeXnicCenter\TeXnicCenter.exe\" /ddecmd \"[goto('%f','%l')]\""

Everything works (the pdf builds, etc.), and if the viewer is already open with the document open, it will update appropriately, but the actual forwardsearch and the associated bringing of the SumatraPDF executable into focus at the right position does NOT work and instead throws the error:

Error

I'm running all the latest versions of:

  • TeXnicCenter 2.02 Stable (64 bit)
  • SumatraPDF 3.1.2 (64-bit)
  • MiKTeX 2.9.6300 (64-bit) (all packages up to date as of today)
  • pdfTeX 3.14159265-2.6-1.40.18
  • makeindex 2.15
  • BibTeX 0.99d

On:

  • Windows 10 64-bit
1

Um yeah... so a full reboot of my computer seems to have fixed this issue. If it comes up again, I may try to report a bug to the TeXnicCenter team.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.