0

TexStudio (TS) keeps corrupting my Latex files. This is what happens.

I use an outside application to generate my latex files (Scientific word). I also use TS to open the file so I can easily compile it and see the current PDF. (I can't do these things in Scientific word easily).

I am not able to tell TS to always use the latest copy of the file on the disk as it changes.

Worst still, what happens is that TS keep the old copy of the file in its cache somewhere, and then it overwrites all the changes I made to the file with this old cache when I open TS later to compile the file.

I lost number of changes due to this. Even without changing the file inside TS, it just overwrites the current file on disk with the old cache. I know this, since when I compile the latex file inside TS, then scientific work gives me a warning message that the file has been changed by another application and asks me if I want to reload the file. ofcouse I say NO when I notice this.

This is even without me making any changes to the file from inside TS. Just opening the file in TS causes this behavior.

I looked at all options and I do not see an option to tell it to always use the content from the disk file and not use old cache copy it has.

This is all on windows 7. Using latest texstudio.

TeXstudio 2.12.4 (hg 6476:3e5c3afa4719)
Using Qt Version 5.6.2, compiled with Qt 5.6.2 R

I am sure I am not the only one who see this problem. Is there any workarounds? I am now afraid to even open textsdio to look at a file, since it can overwrite the latest changes I made to the file from outside using its old copy that it keeps somewhere.

  • Wouldn't the simplest solution be to not use TS and use a comfortable build script? – Johannes_B Apr 26 '17 at 5:45
  • 1
    Ah, you want some kind of Live Preview? That means i am out. – Johannes_B Apr 26 '17 at 5:47
  • 2
    I cannot reproduce your problem as well on Windows 10 with the same workflow as Schweinebacke. And for me, the change in TS is immediate. In TS, under Advanced editor tab in settings, is your monitor open files for external changes option checked? – Troy Apr 26 '17 at 6:26
  • 1
    In my texstudio (portable, on win 10, still version 2.10.8) changed files are reloaded but always silently regardless of the status of the "load silently" option. There is no "monitor" option. In 2.12.6 there is a monitor option and it works, but again only silently. I get no dialog asking me if I want to reload (that would happen in winedt, my normal editor). – Ulrike Fischer Apr 26 '17 at 6:55
  • 1
    I think I have seen or see a similar effect here: I use TS (stable, latest release) and Win7 (latest updates). I use the package svn-multi. So my tex files contain the current \svnid. To commit my files I do not use TS itself, but external commands. After any commit, the \svnid gets updated within the commited tex file and if it was opened in TS during the commit, TS always hangs round about 30 seconds and often (5 out of 6 times) crashes. I have not further investigated the cause. I don't care, because my data is saved in svn. – lAtExFaN Apr 26 '17 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.