0

This question already has an answer here:

I use LyX 2.2. I would like to produce REVTeX 4.1 documents. When running LyX with a document open, I find, via Documents > Settings > Document Class, an item that says "Unavailable: REVTeX (V 4.1)". I found a revtex4-1.layout file in Windows (C:) > Program Files (x86) > LyX 2.2 > Resources > layouts. Please tell me (in detailed steps I can follow) how to to activate use of REVteX 4.1 as a document class. (I do not consider myself 'all that sophisticated' regarding 'how things work'. So I would like to obtain a well-specified process I can follow.) With appreciation.

marked as duplicate by Torbjørn T., TeXnician, Zarko, Claudio Fiandrino, egreg Jun 4 '17 at 11:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Have you tried installing revtex4-1.cls (or whatever is its name) in your LaTeX package manager and running LyX>Tools>Reconfigure. Looks like LyX didn't find that class. What you found is a LyX layout file, which is only a LyX to LaTeX translation file. – PhilipPirrip Apr 26 '17 at 19:10
  • Philip: Perhaps something like this will work. I tried LyX>Tools>Reconfigure and activated some document class choices, but not REVTex 4.1. Unfortunately, I do not know enough to follow your advice or this advice (from a DOWNLOAD file) "Install REVTeX 4.1 by unzipping the files in the appropriate place (usually the texmf-local directory of your local TeX installation) and run texhash or the equivalent command to index the files." Could you coach me through how to find that place and finish this step? Hopefully such will suffice. (I am a novice re this & it is a Windows 10 computer.) Thanks. – TJB Apr 27 '17 at 15:37
  • You're most likely using MiKTeX distribution. There should be a MiKTeX package manager with all the available packages listed. Search for revtex and install v4.1. Then again LyX>Reconfigure. – PhilipPirrip Apr 27 '17 at 16:15
  • Philip: Thank you. I found MiKTeX package manager on my computer. I found it 'knew enough' about REVTeX-related 'things' to give me an option to 'do something.' I did 'whatever' (which presumably did not use the 4.1 download I had obtained). Etc. LyX now recognizes REVTeX 4.1. I selected 4.1 as the document class for my document. LyX reformatted aspects of my document. Perhaps, 'all is OK.' With appreciation. – TJB Apr 27 '17 at 20:19

Browse other questions tagged or ask your own question.