0

I tried everything (I think)!

Now, aastex.sty IS present on my machine but Kile doesn't see it.
Below some info:
kpsewhich -var-value=TEXMFLOCAL gives /usr/local/texlive/texmf-local
locate aastex.sty gives /usr/share/texlive/texmf-dist/tex/latex/aastex/aastex.sty
if I try texhash I get

texhash: /usr/local/texlive/2016/texmf-config: directory not writable. Skipping...
texhash: /usr/local/texlive/2016/texmf-dist: directory not writable. Skipping...
texhash: /usr/local/texlive/2016/texmf-var: directory not writable. Skipping...
texhash: /usr/local/texlive/texmf-local: directory not writable. Skipping...
texhash: Done.

Can somebody, please, tell me what's wrong with my computer?
How can I make Kile see it and use it?

UPDATE the compiler finds the downloaded .sty file if I place it in the same folder folder as the .tex file, but it's practically unusable since the compiler gives many errors.
should I first compile it separately? If so, with what? Thank you

12
  • Exactly what have you installed and exactly which latex is being used by your kile? (it is listed at the top of the log file). Note that ubuntu texlive and vanilla texlive does not share files. If aastex.sty is on ctan it is also available in vanilla texlive. So I'm guessing your kile is not using vanilla texlive.
    – daleif
    Commented Apr 27, 2017 at 16:32
  • I installed exactly what I linked above and the content of the (top of the) log file is the following: This is pdfTeX, Version 3.14159265-2.6-1.40.17 (TeX Live 2016) (preloaded format=pdflatex 2017.4.26) 2 MAY 2017 11:33 entering extended mode restricted \write18 enabled. %&-line parsing enabled. **licentiate.tex (./licentiate.tex LaTeX2e <2017/01/01> patch level 3 Babel <3.9r> and hyphenation patterns for 83 language(s) loaded. My suspect at this point is that Kile is not using Vanilla TexLive. If so, how do I change this? thank you
    – andrea
    Commented May 2, 2017 at 9:38
  • I'd like you to do a test, save this doc in test.tex: \documentclass{article}\begin{dcument}hello\end{document}. Then compile this in Kile, same the log file under another name, say kile_log.log, and then compile by hand in a terminal. Please post both logs. Then we can easily see whether they are using the same installation.
    – daleif
    Commented May 2, 2017 at 10:37
  • I compiled from terminal with pdflatex and its output is exactly the same as that of Kile: This is pdfTeX, Version 3.14159265-2.6-1.40.17 (TeX Live 2016) (preloaded format=pdflatex 2017.4.26) 2 MAY 2017 13:10 entering extended mode restricted \write18 enabled. %&-line parsing enabled. **test.tex (./test.tex LaTeX2e <2017/01/01> patch level 3 Babel <3.9r> and hyphenation patterns for 83 language(s) loaded.
    – andrea
    Commented May 2, 2017 at 11:17
  • This is not the log. I'd like to see the full contents of the .log file. It also lists the path to files.
    – daleif
    Commented May 2, 2017 at 11:20

1 Answer 1

2

SOLUTION (for all other unfortunate souls):
save this page http://adsabs.harvard.edu/abs_doc/aas_macros.sty with .sty extension into the same directory as the tex file and add \usepackage{aas_macros} in the main document preamble

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .