2

How do I make TeXstudio find the MiKTeX file?

I downloaded the MiKTeX distribution first and then TeXstudio and put them in the same folder.

I have tried reinstalling TeXstudio and I have tried deleting the .ini file but neither works...

  • Welcome to TeX SX! Did you install TeX Studio before MiKTeX? Also, certainly do not install TeX Studio in MiKTeX directory – Bernard Apr 30 '17 at 19:13
  • I installed Miktex first and then Texstudio. I placed them both in Programe files.. – Mia Apr 30 '17 at 19:18
  • Don't install TeX Studio in the MiKTeX directory. – Bernard Apr 30 '17 at 19:20
  • I did not, but i did install the two distributions in the same folder – Mia Apr 30 '17 at 19:22
  • That should be no problem. Check if you can launch latex from the command line. Maybe the installation of MiKTeX was defective. – Bernard Apr 30 '17 at 19:27
3

I have downloaded both in portable versions and just fix it adding: "....\texmfs\install\miktex\bin" to Path in System Variables in Environment Variables.

  • Welcome to TeX.SX! – TeXnician Sep 26 '18 at 16:13
2

I faced the same problem. I solved the problem this way:

Options > Configure TeXstudio... > Commands > LaTeX

The LaTeX-commands can be found in a sub-folder of the MiKTeX installation folder.

First time, I tried: "C:/Program Files/LaTeX/MiKTeX 2.9/tex/latex/imakeidx.sty"

After a reboot of TeXstudio, it was able to find most of the other commands too.

Then I realized that this line should actually be pointed to the bin file.

For me that was "C:/Program Files/LaTeX/MiKTeX 2.9/miktex/bin/x64/latex.exe".

It doesn't work perfect yet, but at least it is now able to read and compile something. I hope this helps you too.

0

Close TeXStudio. In Windows Explorer navigate to some folder like: C:\Users\YOUR_ACCOUNT_NAME\AppData\Roaming\texstudio

Delete texstudio.ini file.

Restart TeXStudio.

This fixed it for me.

  • Welcome to TeX.SX! Isn't possible to delete the trash fiels inside texstudio?With texmaker you could do it. – Bobyandbob Sep 27 '18 at 5:30
0

put only in dvi something like that

DVI Viewer (view-dvi): '"C:\Program Files (x86)\texmf\miktex\bin\yap.exe" -1 -s @?"c:ame "?am.dvi"'

and in another option put for default

  • You should NOT need to put c:\ifjfjfaf[iaf\ yap.exe blah blah That tells me other commands will fail IT SHOULD BE yap.exe -1 -s @?"c:ame "?am.dvi"' and if your path is configured correctly it WILL WORK – user170109 Jan 25 at 18:59
0

I installed miktex system wide manually
and then used choco install texstudio in powershell to install texstudio.

After that TeXstudio could find latex and worked perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.