I have a Beamer theme called beamerthemeMittweida.sty that's not available in a package.

At home I just copied the .sty to Miktex\tex\latex\beamer, then updated all packages and I was able to use the theme.

At work I copied the file in the same directory but when I run pdfLaTeX it can't find it. I already used the "Refresh FNDB" function in the MiKTeX settings but still doesn't work. Due to some proxy/firewall stuff I can't use the update function at work.

The log:


! LaTeX Error: File `beamerthemeMittweida.sty' not found.

Type X to quit or  to proceed,
or enter new name. (Default extension: sty)

Enter file name: 

EDIT: the .tex file I'am using:



\author[Name]{Name des Vortragenden}
\title[Kurztitel]{Titel des Vortrags}
\institute[Fachgruppe o.\"a.]{Organisationseinheit}



  • Have you tried copying the file to the folder you're working in, rather than the MiKTeX folder?
    – Werner
    Commented Dec 1, 2011 at 7:42
  • yes, that was my first approach, but then i get a weird "! Missing $ inserted." error at the first \end{frame}
    – Benjamin
    Commented Dec 1, 2011 at 7:54
  • So the issue is solved then. That is, beamerthemeMittweida.sty is found. The ! Missing $ inserted error could be entirely unrelated. With the now-found .sty theme, does the same (and I mean identical) code "at home" give you problems when compiling it "at work?"
    – Werner
    Commented Dec 1, 2011 at 7:58
  • The code ( .tex) is identical, and comes from the person who created the .sty file. Its just the preamble and one frame.
    – Benjamin
    Commented Dec 1, 2011 at 8:24
  • Then post the "preamble and one frame", otherwise it would be impossible to guess what could cause the problem.
    – Werner
    Commented Dec 1, 2011 at 8:26

2 Answers 2


Not really an answer but some comments to long for a comment:

  1. You shouldn't put local files in the main texmf tree of miktex. Use the one called "UserConfig" in the tab "roots" of the miktex settings dialog (click on "show miktex maintained roots"). Or better: create your own small texmf-tree and add its root folder as a new root.

  2. You perhaps don't need the portable version of miktex: It is quite possible to install miktex in a account with restricted user rights "only for you".

  3. If you can't install/update due to a proxy/firewall: You can download the packages at home e.g. with the setup wizard or the package manager (mpm) or some other tools like wget from <CTAN>/systems/win32/miktex/tm/packages/ in a folder on your usb stick and then use this folder as "local repository". In this local repository you must have at least miktex-zzdb1-2.9.tar.lzma and miktex-zzdb2-2.9.tar.lzma and the packages you want to install or update.


Your problem is that the theme mittweida needs some images like the background, title page image, ... So if you have not all files you can't be successful. Have you considered to ask the author of theme mittweida for a complete zip file?

If you have all files:

  1. Delete your changed you did in your global texmf tree.
  2. Create a local texmf, for example c:\localtexmf.
  3. Create now c:\localtexmf\tex\latex\beamer\Mittweida
  4. Copy beamerthemeMittweida.sty and all other files you have into this directory.
  5. Now MiKTeX needs to know that there exists your local texmf. With the window MiKTeX Options (Admin) you can click on roots and add your localtexmf.
  6. The last step is to refresh your filename database (same window, click on General, then Refresh FNDB).

Now your TeX document should compile.

If not then there was something wrong with step 4. This theme needs images files to run. So all of them must be copied into the directory.

I suppose you do not have all neccesary files if the error message appears once again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .