0

I am putting several papers together in a report class as separate chapters. All figures and tables within each paper need to start with number 1 without referencing in which chapter/paper they are (e.g. there is Figure 1 in Chapter 1, Chapter 2, etc.). To control the numbering within sections/chapters, I had a look at this question: Continuous v. per-chapter/section numbering of figures, tables, and other document elements

This is where I found the caption solution with figurewithin and tablewithin.

When I use the following MVE, what I get is Figure .1 - there is always a dot before the figure number, I guess that the chapter number is meant to be there. However, I need to have there only Figure 1 instead of Figure .1:

\documentclass[a4paper, 11pt, english]{report}
\usepackage[T1]{fontenc}
\usepackage[figurewithin=chapter, tablewithin=chapter]{caption}

\begin{document}
\include{Paper1}
\end{document}

Paper1.tex looks this way:

\chapter{Paper I Title}
\section{Introduction}
\begin{table}[htb]
\centering
\begin{tabular}{@{}p{12cm}p{4cm}@{}}
\toprule
BFL                                                                         \\ \midrule
\textit{IC:} Text. \\
\textit{I:} Text.                \\
\\ \bottomrule
\end{tabular}
\caption{Caption title}
\end{table}
  • 2
    I think you must have some more settings, I get Table 1.1. Anyway, try to set \renewcommand\thetable{\arabic{table}} and similar for \thefigure after including caption. – StefanH May 2 '17 at 7:39
  • youre right - I didnt copy them all since they are many and I wasn`t aware of the interplay. The \renewcommand solution works fine by itself, thank you! – latexQ May 2 '17 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.