1

I cannot manage to print bibliography with Biblatex, and \cite{XXX} just provides XXX in text.

Here a MWE:

\documentclass{memoir}

\usepackage{lipsum}
\usepackage[style=ieee,backend=bibtex]{biblatex}
\addbibresource{bibliography.bib}

\begin{document}

\chapter{blablabla}
\lipsum[1-2] \cite{Campbell2004}

\end{document}

Bibliography.bib:

@book{Morgan2005,
author = {Morgan, Peter},
isbn = {978-0-8247-0983-9},
issn = {0-8247-0983-7},
publisher = {Taylor {\&} Francis Group, LLC},
title = {{Carbon fibers and their composites}},
year = {2005}
}

I'm using MiKTeX portable 2.9, Texmaker 4.5. Already tried:

  • Using biber and bibtex as backend;
  • Cleaning temp files;
  • Already running pdflatex -> Bib(la)tex -> pdflatex (x2);
  • bibliography.bib is already a part of the structure and provides quick link.

Output: enter image description here

  • 2
    Nowadays it is preferable to use Biber, you will have to tell your editor about it, though Biblatex with Biber: Configuring my editor to avoid undefined citations. The error message from BibTeX suggests you use a 'build' folder. I suggest you don't do that, then things should work without further modifications. – moewe May 5 '17 at 8:56
  • Looks as if you changed the build process and tried to move files to some output folder build but didn't do it correctly. – Ulrike Fischer May 5 '17 at 8:56
  • @UlrikeFischer, I already corrected that error. Still get the same result.. – Tiago Correia May 5 '17 at 8:57
  • If you must have a build folder, have a look at tex.stackexchange.com/q/184204/35864 – moewe May 5 '17 at 8:57
  • 1
    @UlrikeFischer No, the error isn't there anymore, the aux one. I had build subdirectory on, but when I removed it, that particular error was gone. – Tiago Correia May 5 '17 at 9:03
1

After all @UlrikeFischer was right.

Texmaker still was trying to find the aux file in the directory /build, even with that option disabled. Had to manually delete that in Options.

Thank you very much!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.