0

I read the answers and I'm not getting it. Some of them tell me to use preferences, others tell me to input

%!TEX option = --shell-escape

at the start.

Here's what my screen looks like, to show you that Idk where the Preferences tab is.

Basically want to convert that pic to png.

For efficiency in providing solutions, I'll provide the code in case there may be anything wrong with it:

\documentclass[convert=true]{standalone}

\usepackage{amsmath, amssymb}

\begin{document}
\(\{P,Q\}\vdash R \)
\end{document}

It would be a great help to fix this. Thanks.

EDIT. Here's the result after adding the --enable-18 as requested.

  • Is this really a question about shell-escape or do you just not have imagemagick or ghostscript? You need one of those to do the conversion (see manual of standalone). – TeXnician May 6 '17 at 12:58
  • @TeXnician Oh. Sorry, I don't know what those are. – Mad Maniac May 6 '17 at 13:00
  • Then you are probably not failing with shell-escape. Please read the manual! – TeXnician May 6 '17 at 13:00
  • Sorry. Good point. Technically, I thought standalone was simple enough that reading the package would be unnecessary. I guess not. – Mad Maniac May 6 '17 at 13:09
1

Here's a quick answer utilizing this post (following picture comes from it):

tm shell escape

You can just add --enable-write18 (or --shell-escape respectively) to your pdflatex command.

  • Please check the edit. The conversion still failed. – Mad Maniac May 6 '17 at 12:56
  • @OsamaKawish Have you also tried --shell-escape? – TeXnician May 6 '17 at 12:57
  • Yes. I attempted both. – Mad Maniac May 6 '17 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.