2

I created a simple BibTeX file as well as a simple LaTeX file that references said BibTeX file. When I compile document in AUCTeX using C-c C-a, the bibliography section doesn't appear and the citations are broken: according to the AUCTeX manual this command should run the LaTeX-BibTeX-LaTeX-LaTeX cycle. The file itself is fine as verified by running the same cycle manually.

%% Bibliography.bib
@book{WEN08,
    Author = {Jochen Wengenroth},
    Date-Added = {2017-05-08 08:16:51 +0000},
    Date-Modified = {2017-05-08 08:19:24 +0000},
    Publisher = {de Gruyter},
    Title = {Wahrscheinlichkeitstheorie},
    Year = {2008}}

%% MyDoc.tex
\documentclass[11pt]{article}
\usepackage{cite}

\begin{document}

\title{My Article}
\author{Nobody Jr.}
\date{Today}
\maketitle

Blablabla said Nobody ~\cite{WEN08}. 

\bibliography{Bibliography}{}
\bibliographystyle{plain}
\end{document}

Resulting pdf file with a blank bibliography and a broken citation


AUCTeX 11.90.0
Emacs 25.1.1
TeX Live 2016, v. 3.14159265
macOS Sierra, v. 10.12.4

  • 2
    I tried with repeated C-c: the first attempt has “Default LaTeX”, the subsequent ones have “Default View”. There's no offer about doing BibTeX, so C-c C-a doesn't do it either. So it seems a bug of AUC-TeX: it is supposed to do that, but it doesn't – egreg May 8 '17 at 9:29
  • @JosephWright: I tried running it from the command line and indeed the bibliography was generated. So if this is a problem with my AUCTeX installation, where can I ask for help? Not in this forum? – Evan Aad May 8 '17 at 9:35
  • 1
  • 1
  • @egreg: I don't think the bug report you linked to is applicable to the present situation, since it seems that in the bug report the problem was the existence of multiply defined labels, whereas in the present case there are no multiply defined labels. – Evan Aad May 8 '17 at 10:19

Browse other questions tagged or ask your own question.