2

I am generally a user of natbib but the elsarticle document class (required to submit to a journal) won't allow it so I am using amsrefs and faced with a very strange situation. Using the below code:

\documentclass[preprint,12pt,authoryear]{elsarticle}

\usepackage[author-year]{amsrefs}

\begin{document}

Bundling can be used to incentivise consumers to alter their purchasing habits \cite{Adams1976}. 

\newpage

\bibliographystyle{elsarticle-harv}

\bibliography{Mendeley2}

\end{document}

\endinput

Yields the result

Bundling puzzle

This sort of thing never occurred to me when using natbib. Any help would be massively appreciated.

  • amsrefs is an alternative to bibtex or biblatex not something to be used with a bib file. (It is hardly ever used in practice I suspect) (or if it is used with bibtex it has to be used with its special conversion bib style) (that is one of amsra.bst amsrn.bst amsrs.bst amsru.bst amsry.bst – David Carlisle May 8 '17 at 19:13
  • @DavidCarlisle - The OP's claim that the elsarticle document class doesn't allow natbib is incorrect. – Mico May 8 '17 at 19:56
  • I'm wondering if perhaps you tried to load natbib with package options that conflicted with the package options used when elsarticle loaded natbib. That would've generated a warning about an option clash, which might've caused some confusion. – Nicola Talbot May 8 '17 at 20:02
  • Thank you all for your responses. @DavidCarlisle was correct in that natbib does indeed work with elsarticle; I had to make some additional tweaks to my normal template to make it work (as per Nicola's post). – Tim B May 8 '17 at 20:06
1

You wrote:

... but the elsarticle document class ... won't allow [natbib] ...

On which basis do you make this claim? In fact, the elsarticle document class loads natbib automatically -- a fact which is mentioned on page 1 of the user guide of the elsarticle class. One doesn't generally call this a "won't-allow" situation, right? (Were you maybe confusing elsarticle with its predecessor, named elsart?) Conversely, as @egreg has pointed out in a comment, the amsrefs package is not suitable for the elsarticle document class -- and hence shouldn't be loaded to begin with.

If you use the elsarticle-harv bibliography style, just be sure to provide authoryear as one of the document class options.

enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{mybib.bib}
@article{adams-yellen:1976,
  author = "James Adams and Janet Yellen",
  title  = "Commodity Bundling and the Burden of Monopoly",
  journal= "Quarterly Journal of Econonomics",
  year   = 1976,
  volume = 90,
  number = 3,
  pages  = "475-498",
}
\end{filecontents}

\documentclass[preprint,12pt,authoryear]{elsarticle}
\bibliographystyle{elsarticle-harv}
\begin{document}
\noindent
\cite{adams-yellen:1976}
\section*{References}
\bibliography{mybib}
\end{document}
  • I'd also point out that, on the contrary, amsrefs should not be loaded with elsarticle. – egreg May 8 '17 at 20:07
  • @egreg - Thanks, I'll add this to the answer. – Mico May 8 '17 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.